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1 Introduction 
1.1 About This Manual 

This manual describes the Hilscher EU5C-SWD-PROFINET Gateway. Here 
you will find information on how to install, configure and operate the 
gateway. 

This manual is intended for automation technicians and engineers. Detailed 
knowledge of PROFINET IO is presumed. In addition, readers should also 
be familiar with the handling of the SmartWire-DT system. 

 

 
 

IMPORTANT! 

 To avoid personal injuries or damage of electrical devices, please read 
this manual carefully before installing and using the EU5C-SWD-
PROFINET Gateway.  

 Please first read the Safety chapter on page 15 ff. 

 

1.1.1 List of Revisions 
Index Date Chapter Revisions 
1 2012-06-01 All Created 

2 2012-06-25 1.3 Scope of Delivery section substituted by 
Software Package section. 

1.3 Installation program for USB driver added 3 2012-07-16 

1.3.3 Section Notes on Installing the USB driver 
added 

Table 1: List of Revisions  
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1.1.2 Conventions in this Manual 
Notes, operation instructions and results of operation steps are marked as 
follows: 

Notes 
 
 

 

Important: <important note> 

 

 
Note:  <note> 

 

 

<note, where to find further information> 

 

Operation Instructions 
 

1. <instruction> 

2. <instruction> 
 

or 
 

 <instruction> 

 

Results 
 

 <result> 

 

 

 

For a description of the labeling of Safety Messages, see Labeling of 
Safety Messages section on page 19. 
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1.2 Versions of Devices, Firmware, Software Tools, Drivers 
and Device Description File 

The hardware revisions and software versions functionally belong together. 
This means that certain revisions of the hardware of the gateway need 
certain versions of firmware, software and drivers, in order to function 
properly.  
This section lists the hardware revisions and the versions of the firmware, 
the configuration software, the drivers and the device description file which 
functionally belong together and to which all instructions in this manual 
refer. 

Device and Firmware 
This manual refers to the following hardware revision and firmware version 
of the EU5C-SWD-PROFINET Gateway:  
 

Device type name Protocol Part number Hardware 
revision 

Firmware Firmware 
version 

EU5C-SWD-PROFINET PROFINET IO 9233.920 3 E030D0U0.nxf 1.0.x.x 

Table 2: Reference to Hardware and Firmware 

Software Tools 
This manual refers to the following software versions: 
 

Software Manufacturer Version 
Ethernet Device Configuration Tool  Hilscher 1.501 
STEP 7 Siemens 5.4 SP5 / 5.5 
SWD-Assist Eaton 1.60 

Table 3: Reference to Software Tools 

Drivers 
This manual refers to the following driver versions: 
 

Driver File name Version 
USB Driver by Windows ® usbser.sys - 

Table 4: Reference to Drivers 

Device Description File 
This manual refers to the following device description file: 
 

Device description file File name 
GSDML for EU5C-SWD-
PROFINET Gateway 

GSDML-V2.25-Hilscher-EU5C-SWD-201206xx.xml 

Table 5: Reference to Device Description File 
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1.3 Software Package 
For the EU5C-SWD-PROFINET Gateway, the software package  
EU5C-SWD-SW (order number 3233.920) is available from Hilscher.  
The package contains a product DVD and a Mini-USB cable.   
You can download the complete product DVD as ZIP file from our website 
www.hilscher.com under Products > Gateways or under Support > 
Downloads. 

1.3.1 Contents of the Product DVD 
The product DVD includes:  

• GSDML Device description file  

• Firmware 

• Eaton SWD-Assist software 

• Wizard for installing the software available on the DVD and for 
downloading the latest version of the SWD-Assist software from the 
internet 

• Installation program for USB driver (USB driver is needed if the gateway 
is to be connected to a PC in order to use the Eaton SWD-Assist 
software) 

• Installation program for the Hilscher Ethernet Device Configuration Tool  

• Documentation in PDF format 

• Installation program for Adobe Reader 

The product DVD has the following directories: 
 

Directory Contents 
Documentation PDF manuals in German and English and installation program for 

Adobe Reader 

Driver Folder containing installation program (setup.exe) and .INF- and 
.CAT- files for Windows USB driver. 

EDS GSDML device description file and bitmap files to be imported in 
PROFINET IO engineering tool 

Firmware Loadable gateway firmware  

fscommand Files for start screen of product DVD 

Software SWD-Assist software 
Folder: Software\SWD-Assist 
Wizard for installing the software available on the DVD and for 
downloading the latest version of the SWD-Assist software from the 
internet 
Folder: Software\Setup 
Installation program for Ethernet Device Configuration Tool 
Folder: Software\EnDeviceCfg 

Table 6: Directory of DVD  

http://www.hilscher.com/
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Note: You can use the wizard on the product DVD to download updates of 
the Eaton SWD-Assist software, or you can download SWD-Assist directly 
from the www.moeller.net website under Support > Download Center. 
Direct link:  
http://downloadcenter.moeller.net/en/software.a487d8b7-da91-486f-b3ba-a7ca2035db99 
You can download other content stored on the DVD from the Hilscher 
website www.hilscher.com under Support > Downloads. 

 

1.3.2 How to Use the Product DVD 
Insert the product DVD into your DVD drive.   
If the auto start function of your DVD drive is enabled, the start screen of 
the DVD automatically opens. You can also start the DVD by double-
clicking the SmartWire.exe file in the root directory of the DVD. 

In the menu of the start screen of the DVD, click Install Planning and 
Configuration Tools to open a wizard for installing the software programs 
stored on the DVD and for downloading the latest version of the Eaton 
planning software SWD-Assist from the internet. The wizard provides the 
following options: 

USB driver: installs USB driver for Windows on your PC. 

SWD Planning Software SWD-Assist V1.60: installs version 1.60 of the 
SWD-Assist software (provided on the DVD) on your PC. 

Download Center SWD-Assist, manual update check: connects your 
browser to a web page where you can download the latest version of the 
SWD-Assist software. 
Ethernet Device Scanner/Configuration Tool: installs the Hilscher 
Ethernet Device Configuration Tool on your PC. 

In the menu of the start screen of the DVD, you can also open folders 
(directories) in which the documentation, the USB driver and the GSDML 
file are stored.  

 

http://downloadcenter.moeller.net/en/software.a487d8b7-da91-486f-b3ba-a7ca2035db99
http://www.hilscher.com/
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1.3.3 Notes on Installing the USB Driver 
If you intend to use the SWD-Assist software, you should first install the 
USB driver on your PC before you connect the EU5C-SWD-PROFINET 
Gateway via USB. 

To install the USB driver from the DVD, choose Install Planning and 
Configuration Tools in the DVD menu to open the installation wizard, then 
select the USB driver option. As an alternative, you can double-click the 
setup.exe file in the Driver\USB\Windows folder of the DVD.   
Then simply follow the instructions of the installation routine. 
 

 

Note: Under Windows XP, the installation process is not yet finished by 
the setup. The installation process has to be completed in the Found new 
Hardware Wizard, which automatically opens after you have connect the 
gateway to a PC via USB cable for the first time (see below). 

 

Windows XP 
When you connect the gateway via USB for the first time to a PC running 
under Windows XP, the Found New Hardware Wizard opens:  

 Answer the question Can Windows connect to Windows Update…?, 
with No, not this time. Then click Next button. 

 If you have already carried out the setup of the USB driver (as 
recommended), you can ignore the wizard’s request to insert a CD or 
floppy disk. Answer the What do you want the wizard to do? question 
by selecting the Install the software automatically option, then click 
Next button. 

 After the installation is complete, click Finish button. 

Windows 7 
If you have carried out the setup of the USB driver before first connecting 
the USB cable (as recommended), then the USB connection is instantly 
operable under Windows 7. 

Uninstall USB Driver 
If you want to remove the USB driver from a PC running under Windows 
XP, choose Start menu > Control Panel > Add or Remove Programs, 
then select:  
Windows Driver Package – Hilscher GmbH (hilusbser) Ports entry. 
Click Change/Remove button to uninstall the driver. 

Under Windows 7, choose Start menu > Control Panel > Uninstall a 
program, then select:  
Windows Driver Package – Hilscher GmbH (hilusbser) Ports entry. 
Click Uninstall/Change button to uninstall the driver. 
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1.4 Documentation Overview 
Besides this user manual at hand (path on product DVD: 
Documentation\english\1.Device Manuals\EU5C-SWD-
PROFINET\EU5C-SWD-PROFINET UM 01 EN.pdf), the following 
documents are also relevant for the user of the EU5C-SWD-PROFINET 
Gateway:  
 

Title Contents  Publisher Document ID Path on product DVD 
SmartWire-DT 
Units 

Information on engineering, 
installation and 
programming of the 
individual SmartWire-DT 
slaves. 

Eaton 05/11 
MN05006001Z-
EN 

Documentation\english\ 
2.SmartWire-DT\ 
MN05006001Z_EN.pdf 

SmartWire-DT 
The System 

Information on function, 
installation, commissioning 
and diagnostics of the 
SmartWire-DT system. 

Eaton 02/11 
MN05006002Z-
EN 

Documentation\english\ 
2.SmartWire-DT\ 
MN05006002Z_EN.pdf 

Ethernet Device 
Configuration 

Operating Instruction 
Manual of Hilscher Ethernet 
Device Configuration Tool. 

Hilscher  DOC050402OI05
EN 

Documentation\english\ 
3.Ethernet Device 
Configuration\ 
Ethernet Device 
Configuration OI 05 
EN.pdf 

PROFINET 
Installation 
Guideline for 
Cabling and 
Assembly 

Information on PROFINET 
cabling. 

PROFIBUS 
Nutzer-
organisation 
e.V. 

Order No: 8.072 
Identification: 
TC2-08-0002 

Documentation\english\ 
4.PROFINET Guideline 
Assembly\ 
PROFINET_Guideline_Assemb
ly_8072_V10_Jan09.pdf 

SWD-Assist 
Online help 

Online help for SWD-Assist 
planning software 

Eaton - Included in SWD-Assist software 

Table 7: Documentation Overview 

 

 

 



Introduction 12/103 

SmartWire-DT Gateway | EU5C-SWD-PROFINET  
DOC120304UM03EN | Revision 3 | English | 2012-07 | Released | Public  © Hilscher 2012 

1.5 Legal Notes 

1.5.1 Copyright 
© Hilscher 2012, Hilscher Gesellschaft für Systemautomation mbH   

All rights reserved. 

The images, photographs and texts in the accompanying material (user 
manual, accompanying texts, documentation, etc.) are protected by 
German and international copyright law as well as international trade and 
protection provisions. You are not authorized to duplicate these in whole or 
in part using technical or mechanical methods (printing, photocopying or 
other methods), to manipulate or transfer using electronic systems without 
prior written consent. You are not permitted to make changes to copyright 
notices, markings, trademarks or ownership declarations. The included 
diagrams do not take the patent situation into account. The company 
names and product descriptions included in this document may be 
trademarks or brands of the respective owners and may be trademarked or 
patented. Any form of further use requires the explicit consent of the 
respective rights owner. 
 

1.5.2 Important Notes 
The user manual, accompanying texts and the documentation were created 
for the use of the products by qualified experts, however, errors cannot be 
ruled out. For this reason, no guarantee can be made and neither juristic 
responsibility for erroneous information nor any liability can be assumed. 
Descriptions, accompanying texts and documentation included in the user 
manual do not present a guarantee nor any information about proper use 
as stipulated in the contract or a warranted feature. It cannot be ruled out 
that the user manual, the accompanying texts and the documentation do 
not correspond exactly to the described features, standards or other data of 
the delivered product. No warranty or guarantee regarding the correctness 
or accuracy of the information is assumed.  

We reserve the right to change our products and their specification as well 
as related user manuals, accompanying texts and documentation at all 
times and without advance notice, without obligation to report the change. 
Changes will be included in future manuals and do not constitute any 
obligations. There is no entitlement to revisions of delivered documents. 
The manual delivered with the product applies.  

Hilscher Gesellschaft für Systemautomation mbH is not liable under any 
circumstances for direct, indirect, incidental or follow-on damage or loss of 
earnings resulting from the use of the information contained in this 
publication. 
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1.5.3 Exclusion of Liability 
The software was produced and tested with utmost care by Hilscher 
Gesellschaft für Systemautomation mbH and is made available as is. No 
warranty can be assumed for the performance and flawlessness of the 
software for all usage conditions and cases and for the results produced 
when utilized by the user. Liability for any damages that may result from the 
use of the hardware or software or related documents, is limited to cases of 
intent or grossly negligent violation of significant contractual obligations. 
Indemnity claims for the violation of significant contractual obligations are 
limited to damages that are foreseeable and typical for this type of contract. 

It is strictly prohibited to use the software in the following areas: 

• for military purposes or in weapon systems;  

• for the design, construction, maintenance or operation of nuclear 
facilities; 

• in air traffic control systems, air traffic or air traffic communication 
systems;  

• in life support systems;  

• in systems in which failures in the software could lead to personal injury 
or injuries leading to death. 

We inform you that the software was not developed for use in dangerous 
environments requiring fail-proof control mechanisms. Use of the software 
in such an environment occurs at your own risk. No liability is assumed for 
damages or losses due to unauthorized use. 

1.5.4 Warranty 
Although the hardware and software was developed with utmost care and 
tested intensively, Hilscher Gesellschaft für Systemautomation mbH does 
not guarantee its suitability for any purpose not confirmed in writing. It 
cannot be guaranteed that the hardware and software will meet your 
requirements, that the use of the software operates without interruption and 
that the software is free of errors. No guarantee is made regarding 
infringements, violations of patents, rights of ownership or the freedom from 
interference by third parties. No additional guarantees or assurances are 
made regarding marketability, freedom of defect of title, integration or 
usability for certain purposes unless they are required in accordance with 
the law and cannot be limited. Warranty claims are limited to the right to 
claim rectification. 
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1.5.5 Export Regulations 
The delivered product (including the technical data) is subject to export or 
import laws as well as the associated regulations of different counters, in 
particular those of Germany and the USA. The software may not be 
exported to countries where this is prohibited by the United States Export 
Administration Act and its additional provisions. You are obligated to 
comply with the regulations at your personal responsibility. We wish to 
inform you that you may require permission from state authorities to export, 
re-export or import the product. 

 

1.5.6 Registered Trademarks 
SmartWire-DT is a registered trademark of Eaton Industries GmbH, Bonn. 

Windows® 2000, Windows® XP, Windows® Vista and Windows® 7 are 
registered trademarks of the Microsoft Corporation.  

S7 and STEP 7 are registered trademarks of Siemens AG. 

Adobe-Acrobat® is a registered trademark of the Adobe Systems 
Incorporated. 

PROFINET is a registered trademark of PROFIBUS International, 
Karlsruhe. 

All other mentioned trademarks are property of their respective legal 
owners. 
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2 Safety 
2.1 General Note 

The user manual, all accompanying texts and the documentation are 
written for the use of the products by educated personnel. When using the 
products, all safety instructions, property damage messages and all valid 
legal regulations have to be observed. Technical knowledge is presumed. 
The user has to assure that all legal regulations are obeyed. 

2.2 Intended Use 
The purpose of the EU5C-SWD-PROFINET Gateway described in this user 
manual is to create a connection between SmartWire-DT slaves and an 
overriding PROFINET IO controller (master device).  

2.3 Personnel Qualification 
The EU5C-SWD-PROFINET Gateway must be installed, configured and 
removed by qualified personnel only. Job-specific technical skills for people 
professionally working with electricity must be present concerning the 
following issues: 

• Safety and health at work 

• Mounting and connecting of electrical equipment 

• Measurement and analysis of electrical functions and systems 

• Evaluation of the safety of electrical systems and equipment 

• Installing and configuring IT systems 

2.4 References Safety  
[S1] ANSI Z535.6-2006 American National Standard for Product Safety Information in 

Product Manuals, Instructions, and Other Collateral Materials 
[S2] IEC 60950-1, Information technology equipment - Safety -  

Part 1: General requirements, 
(IEC 60950-1:2005, modified); German Edition EN 60950-1:2006 

[S3] EN 61340-5-1 and EN 61340-5-2 as well as IEC 61340-5-1 and IEC 61340-5-2 
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2.5 Safety Instructions to Avoid Personal Injury 
To ensure your own personal safety and to avoid personal injury, you must 
read, understand and follow the following safety instructions in this manual 
and all warning messages, before you install and operate the EU5C-SWD-
PROFINET Gateway. 

2.5.1 Electrical Shock Hazard 
Take care of the following safety measures before installing or uninstalling 
the gateway: 

• First disconnect the power plug of the device.  

• Make sure that the device is disconnected from the power supply. 

• Cover or enclose neighboring units that are live.  

Devices that are designed for mounting in housings or control cabinets 
must only be operated and controlled after they have been installed with 
the housing closed. Desktop or portable units must only be operated and 
controlled in enclosed housings. 

2.5.2 Danger of Unintended Starting Up of Machines 
• Install automation devices and related operating elements in such a way 

that they are well protected against unintentional operation. 

• Emergency stop devices complying with IEC/EN 60204-1 must be 
effective in all operating modes of the automation devices. Unlatching 
the emergency-stop devices must not cause restart. 

• You must take safety precautions (emergency switching off) in the 
external circuitry of the EU5C-SWD-PROFINET and any power modules 
type EU5C-SWD-PF1-1 or EU5C-SWDPF2-1 that are used. To do so, 
plan to switch off the power supply to the contactor coils AUX. 

• Measures should be taken to ensure the proper restart of programs 
interrupted after a voltage dip or failure. This should not cause 
dangerous operating states even for a short time. If necessary, 
emergency stop devices should be implemented. 

• Wherever faults in the automation system may cause damage to 
persons or property, external measures must be implemented to ensure 
a safe operating state in the event of a fault or malfunction (for example, 
by means of separate limit switches, mechanical interlocks etc.). 
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2.6 Safety Instructions to Avoid Property Damage 
To avoid damage to your EU5C-SWD-PROFINET Gateway or your 
communication system, you must read, understand and follow the following 
safety instructions and all safety instructions and warnings in this manual 
concerning property damage, before you install and operate the gateway. 

2.6.1 General Safety Instructions Concerning Supply Voltage 
• In safety-relevant applications the power supply providing power to the 

SmartWire-DT system must feature a PELV power feed module 
(protective extra low voltage). 

• Switch off the power supply, if you are reconnecting slaves in the 
SmartWire-DT system or reconnecting the ribbon cable connection. 
Otherwise the SmartWire-DT slaves can be destroyed! 

• The gateway has protection against polarity reversal for the 24-V-DC-
POW supply. However, if the gateway is connected via the serial 
interface to an earthed device (for example to a PC), the gateway can be 
destroyed, if the polarity of the power supply is reversed! 

• The functional earth (FE) must be connected to the protective earth (PE) 
or to the potential equalization. The system installer is responsible for 
implementing this connection. 

• Connecting cables and signal lines should be installed so that inductive 
or capacitive interference does not impair the automation functions. 

• Suitable safety hardware and software measures should be 
implemented for the I/O interface so that a line or wire breakage on the 
signal side does not result in undefined states in the automation devices. 

2.6.2 Device Destruction by Exceeding Allowed Supply Voltage 
The EU5C-SWD-PROFINET Gateway must only be operated with the 
specified supply voltage. 

• Make sure that the limits of the allowed range for the supply voltage are 
not exceeded. A supply voltage above the upper limit can cause severe 
damage of the gateway!  

• A supply voltage below the lower limit can cause malfunction of the 
gateway!  

• Ensure a reliable electrical isolation of the low voltage for the 24 volt 
supply. Only use power supply units complying with IEC 60364-4-41 
(VDE 0100 Part 410) or HD 384.4.41 S2. 

The allowed range for the supply voltage is indicated in section Technical 
Data on page 94. 
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2.6.3 Electrostatic Sensitive Device 
The EU5C-SWD-PROFINET Gateway is sensitive to electrostatic 
discharge, which can cause internal damage and affect its normal 
operation. Therefore adhere to the necessary safety precautions for 
components that are vulnerable to electrostatic discharge when you install 
or remove the gateway. Follow the guidelines listed hereafter when you 
handle the gateway: 

• Touch a grounded object to discharge potential static before you handle 
the gateway. 

• Wear an approved grounding wriststrap. 

• If possible, use a static-safe workstation. 

• When not in use, store the device in appropriate static-safe packaging. 
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2.7 Labeling of Safety Messages 
• The Section Safety Messages at the beginning of a chapter are 

pinpointed particularly. They are highlighted by a specific safety symbol 
and a signal word according to the degree of endangerment. In the 
safety message, the nature of the hazard is indicated.  

• The Integrated Safety Messages embedded in operating instructions 
are highlighted by a signal word according to the degree of 
endangerment and possibly by a safety symbol. In the safety message, 
the nature of the hazard is indicated. 

 

Safety 
symbol 

Sort of warning or principle 

 

Warning of personal injury or property damage 

 

Warning of damages by electrostatic discharge 

 

Principle: Disconnect the power plug 

Table 8: Safety Symbols and Sort of Warning or Principle 

 

Signal word Meaning Meaning USA 

 Indicates a direct hazard with high 
risk, which will have as consequence 
death or grievous bodily harm if it is 
not avoided. 

Indicates a hazardous situation which, if not 
avoided, will result in death or serious injury. 

 Indicates a possible hazard with 
medium risk, which will have as 
consequence death or (grievous) 
bodily harm if it is not avoided. 

Indicates a hazardous situation which, if not 
avoided, could result in death or serious 
injury. 

 Indicates a minor hazard with 
medium risk, which could have as 
consequence personal injury, if it is 
not avoided. 

Indicates a hazardous situation which, if not 
avoided, may result in minor or moderate 
injury. 

 Indicates a property damage 
message. 

Indicates a property damage message. 

Note Indicates an important note in the 
manual. 

Indicates an important note in the manual.  

Table 9: Signal Words 

In this document, the safety instructions and property damage messages 
are designed according both to the internationally used safety conventions 
as well as to the ANSI Z535 standard. 
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3 Descriptions and Requirements 
3.1 Device Description EU5C-SWD-PROFINET Gateway 

3.1.1 Overview 
The EU5C-SWD-PROFINET Gateway integrates a SmartWire-DT network 
into a PROFINET network. The Gateway creates a data connection 
between the participants (the slaves) of the subordinate SmartWire-DT 
network and the controller (the master or PLC) of the superordinate 
PROFINET IO network. 

The gateway acts as master in the SmartWire-DT network, and as modular 
IO Device (slave) in the PROFINET network. It thereby presents each 
connected SmartWire-DT participant as individual module to the 
PROFINET IO Controller. 

The cyclic process data is exchanged transparently between both 
networks. 1000 Bytes of process input/output data can in sum be 
exchanged with up to 99 SmartWire-DT participants (slaves). 

 

 
Figure 1: Data Flow EU5C-SWD-PROFINET Gateway 
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3.1.2 Configuration 
The EU5C-SWD-PROFINET Gateway is easily commissioned by an 
automated configuration function: On pushing the configuration button on 
the front of the gateway, the gateway scans the current SmartWire-DT 
network configuration, the so-called actual configuration. It then stores the 
actual configuration as target configuration zero voltage-safe in the device, 
thus making the target configuration available for a comparison of actual 
and targeted SmartWire-DT configuration, which takes place each time the 
gateway is being switched on.  

When the gateway is switched on after a target configuration has already 
been stored, the gateway automatically rescans the connected actual 
configuration and checks it against the target configuration. It then gets 
ready for PROFINET IO and waits for the PROFINET configuration. The 
gateway checks the project configuration, which it receives from the 
PROFINET IO controller, against the target configuration.  
Discrepancies between target and actual, or between target and project 
configurations are reported by the gateway via PROFINET-Diagnosis. 

The gateway is commissioned in PROFINET by using a PROFINET IO 
controller engineering tool and a GSDML device description file, which is to 
be imported into engineering tool. The GSDML file of the gateway is stored 
in the EDS\EU5C-SWD-PROFINET directory of the product DVD, which is 
included in the scope of delivery. The file contains all configuration data 
and all possible SmartWire-DT slaves as I/O modules. 
 

 
Note: The GSDML device description file contains only I/O information for 
SmartWire-DT slaves which were listed as sales products at the time of 
creation of the file. 

 

Eaton SWD-Assist planning software 
In principle, you can build-up and configure a SmartWire-DT network 
without any software tools. However, it is recommended to use the SWD-
Assist software to plan, dimension and document the SmartWire-DT 
network. In SWD-Assist, a project specific GSDML file can be created and 
exported. Using this file gives you the benefit of finding the I/O modules of 
the SmartWire-DT slaves already preconfigured in your PROFINET 
controller engineering tool. 
 

 

For further information, please refer to the SWD-Assist online help. 

 

 
Note: You will find the Eaton SWD-Assist software on the product DVD, 
which is included in the EU5C-SWD-SW software package (order number 
3233.920) available from Hilscher.   
You can use the wizard on the product DVD to download updates of the 
Eaton SWD-Assist software, or you can download SWD-Assist directly 
from the www.moeller.net website under Support > Download Center. 
Direct link:  
http://downloadcenter.moeller.net/en/software.a487d8b7-da91-486f-b3ba-a7ca2035db99 

 

 

http://downloadcenter.moeller.net/en/software.a487d8b7-da91-486f-b3ba-a7ca2035db99
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3.1.3 Interfaces 
The gateway features a SmartWire-DT interface (plug, 8-pole), a 2-port 
switch Ethernet interface (RJ45) and a Mini-USB interface. Via the Mini-
USB interface, the gateway can communicate with the SWD-Assist 
software. 

3.1.4 Diagnosis 
The gateway can be diagnosed by connecting the SWD-Assist software to 
the Mini-USB interface. For further information, please refer to the SWD-
Assist online help. 

The PROFINET IO protocol also provides diagnostic functions. For further 
information, see section Alarms and Diagnosis Controlled by the Gateway 
on page 88. 

3.1.5 Firmware Update 
The EU5C-SWD-PROFINET Gateway is shipped with its most recent 
firmware already loaded. If an update of the firmware should be necessary, 
the update can be done by using an ordinary web browser.  
A web server embedded in the gateway provides a special web page for 
updating the firmware, which can be accessed by the Ethernet interface of 
the gateway. For more details, please refer to the Updating Firmware 
chapter on page 90 ff. 
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3.2 Prerequisites for Operation 
The following prerequisites must be fulfilled to operate the EU5C-SWD-
PROFINET Gateway: 

3.2.1 Network System 
• SmartWire-DT network with maximum number of up to 99 

participants/stations/slaves and maximum extension of up to 600 
meters. 

• PROFINET IO network with PROFINET IO Controller (master) 
respectively PLC. Maximum cable length for one segment (cable 
between two switches) is 100 meters. 

3.2.2 Power Supply 
 

 
 

In safety-relevant applications the power supply providing power for the 
SmartWire-DT system must feature a PELV power feed module 
(protective extra low voltage). 

 

 
 

Ensure a reliable electrical isolation of the low voltage for the 24 volt 
supply. Only use power supply units complying with IEC 60364-4-41 
(VDE 0100 Part 410) or HD 384.4.41 S2. 

 

 
 

You must take safety precautions (emergency switching off) in the 
external circuitry of the EU5C-SWD-PROFINET and any power modules 
type EU5C-SWD-PF1-1 or EU5C-SWDPF2-1 that are used. To do so, 
plan to switch off the power supply to the contactor coils AUX. 

 

 

Important!  
Please take into consideration the total power consumption of your 
SmartWire-DT network and, if necessary, plan for an additional feeder 
module EU5C-SWD-PF2.   
You can find information on the power consumption in the operating 
manuals of the SmartWire-DT devices. 
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3.2.2.1 POW Power Connection 

A Power supply of 24 V DC for the coupling unit and for the Smart-Wire-DT 
slave electronics is needed at the connection POW. 

On the SmartWire-DT gateway, connect the POW and AUX supply 
voltages via separate miniature circuit-breakers or fuses: 

Miniature circuit-breaker 24 V DC for POW 

• Cable protection in accordance with DIN VDE 0641 Part 11, IEC/EN 
60898: 
Miniature circuit-breaker 24 V DC rated operational current 3 A; trip 
types C or Fuse 3 A, utilization class gL/gG 

• Cable protection for cable AWG 24 in accordance with UL 508 und CSA-
22.2 No. 14:  
Miniature circuit-breaker 24 V DC rated operational current 3 A; Tripping 
characteristics C or Fuse 3 A 

3.2.2.2 AUX Power Connection 

If any switching devices are also to be connected, for example via the DIL-
SWD-32-001/002 SmartWire-DT slaves, a 24 V DC supply will also be 
required at the AUX power connection. This provides the supply for 
activating the contactor coils. This supply must be protected by an 
automatic circuit-breaker (3A gG/gl or 3 A miniature circuit-breaker with a Z 
characteristic).   
If switching devices with an activation power greater than 3 A are 
connected, an additional feeder module EU5C-SWD-PF1 or EU5C-SWD-
PF2 must be used. 

On the SmartWire-DT gateway, connect the POW and AUX supply 
voltages via separate miniature circuit-breakers or fuses: 

Miniature circuit-breaker 24 V DC for AUX 

• Cable protection in accordance with DIN VDE 0641 Part 11, IEC/EN 
60898: 
Miniature circuit-breaker 24 V DC rated operational current 3 A; trip type 
Z or Fuse 3 A, utilization class gL/gG 

• Cable protection for cable AWG 24 in accordance with UL 508 und CSA-
22.2 No. 14:  
Miniature circuit-breaker 24 V DC rated operational current 2 A; Tripping 
characteristics Z or Fuse 2 A 

 

 



Device Picture, Connectors and LEDs 25/103 

SmartWire-DT Gateway | EU5C-SWD-PROFINET  
DOC120304UM03EN | Revision 3 | English | 2012-07 | Released | Public  © Hilscher 2012 

4 Device Picture, Connectors and LEDs 
4.1 Device Picture 

  

24 V power supply POW 

PROFINET IO interface (RJ45) 

LEDs communication status 
PROFINET IO  

Mini-USB interface 

Configuration button 

LEDs Gateway 

24 V power supply AUX 

SmartWire-DT connection (plug, 8-
pole) 

Cover for optional address switches 
(address switches are not necessary, 
since gateway address is assigned by 
PROFINET IO Controller) 

 

 
Figure 2: Front View EU5C-SWD-PROFINET Gateway 
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4.2 Positions and Meaning of the LEDs 

4.2.1 Positions of the LEDs 
POW: System status 

APL: Application status 

Config.: Configuration status 

SWD: SmartWire-DT status 

SF: PROFINET system error  

BF: PROFINET bus error 

LINK for channel 0 

Receive/Transmit (RX/TX) for channel 0 

LINK for channel 1 

Receive/Transmit (RX/TX) for channel 1 

 

 

Figure 3: LEDs EU5C-SWD-PROFINET Gateway 
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4.2.2 Descriptions of the LEDs 
 

LED Color State Meaning 
Duo-LED yellow/green 

 (yellow) On Operating system is running, firmware is started. 

  
(green/yellow) 

Flashing Bootloader mode active, firmware not loaded. 

 (green) On Firmware backup active. 

POW 
System 
status 
Number in 
picture:  

 

 (off) Off Power supply for device is missing or hardware defect. 

Duo-LED red/green 

 (green) On The communication on PROFINET and SmartWire-DT is in cyclic 
data exchange and the gateway function is executed. 

 (green) Flashing  
2 s off,  
0.5 s on 

Gateway is initialized, but the communication on PROFINET is not 
in cyclic data exchange. 

 (green) Flashing  
2 s off,  
0.5 s on, 
0.5 s off, 
0.5 s on 

Gateway is initialized, but the communication on SmartWire-DT is 
not in cyclic data exchange. 

 (red)  Flashing  
2 s off,  
0,5 s on 

Gateway is initialized, but the configuration for the communication 
protocol on PROFINET is missing or in error. 

 (red) Flashing  
2 s off,  
0.5 s on, 
0.5 s off, 
0.5 s on 

Gateway is initialized, but the configuration for the communication 
protocol on SmartWire-DT is missing or in error. 

APL 
Application 
status  

Number in 
picture:  

 
 

 (red) On Gateway has detected an error during the initialization: Missing 
configuration, error in configuration or internal error. 

Duo-LED red/green 

 (green) On The planned configuration complies with the gateway target 
configuration. Data exchange between Gateway and PLC via 
PROFINET takes place. 

 (green) Flashing  The planned configuration does not comply with the gateway target 
configuration, but is compatible with it.  
Data exchange between gateway and PLC via PROFINET takes 
place. 

 (red) On The planned configuration and the gateway target configuration are 
not compatible. 
No data exchange between gateway and PLC via PROFINET. 

Config. 
Configuration 
status 
Number in 
picture: 

 

 (off) Off No communication with the PROFINET IO controller or the gateway 
does not contain a project configuration. 

Table 10: Description of the LEDs (1) 
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LED Color  State Meaning 

Duo-LED red/green/orange (orange = red/green at same time) 

 (green) On The current actual configuration complies with the gateway target 
configuration. 
Data exchange between gateway and SmartWire-DT slaves takes 
place. 

 (red) Flashing  A necessary SmartWire-DT slave is missing or the gateway target 
configuration does not comply with the actual configuration. 
No data exchange between gateway and SmartWire-DT slaves. 

 (green) Flashing  Slave addressing is active (after power On or the download of a 
planned configuration with empty modules). 
No data exchange between gateway and SmartWire-DT slaves. 

 (red) On Short-circuit on the 15 V power supply or no SmartWire-DT slave is 
connected. 
No data exchange between gateway and SmartWire-DT slaves. 

SWD 
Status 
SmartWire-DT 
Number in 
picture: 

 

 (orange) 
Flashing After having pressed the configuration button: The gateway reads 

the current actual configuration and stores it as target configuration. 

Duo-LED red/green 

 (red) On Watchdog timeout; channel-, generic or extended diagnosis 
present; system error. 

 (red) Flashing 
cyclically at 
2 Hz (for 
3 sec.) 

DCP signal service is initiated via the bus. 

SF 
PROFINET 
System Error 
Number in 
picture: 

 

 (off) Off No error. 

Duo-LED red/green 

 (red) On No configuration; or low speed physical link; or no physical link. 

 (red) Flashing 
cyclically at 
2 Hz 

No data exchange. 

BF 
PROFINET 
Bus Error 
Number in 
picture: 

 
 (off) Off No error. 

LED green 

 (green) On Gateway has connection to Ethernet. 

LINK/RJ45 
Ch0 & Ch1 
Numbers in 
picture: 

 &   (off) Off Gateway has no connection to Ethernet. 

LED yellow RX/TX/RJ45 
Ch0 & Ch1 
Numbers in 
picture: 

 &  

  
(yellow) 

Steady on or 
flashing  

Gateway sends/receives Ethernet frames. 

Table 11: Description of the LEDs (2) 
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4.3 Pinning PROFINET IO Interface 
The following picture shows the pinning of the PROFINET IO interface of 
the EU5C-SWD-PROFINET Gateway: 

 
Figure 4: Pinning of the Ethernet Interface (RJ45) 

Pin Signal Description 
1 TX + Transmit Data + 

2 TX –  Transmit Data – 

3 RX + Receive Data + 

4 TERM 

5 TERM 
Bob Smith Termination 

6 RX – Receive Data – 

7 TERM 

8 TERM 
Bob Smith-Termination 

Tabelle 1: Ethernet Interface Channel 0 and Channel 1 Pin Assignment (RJ45) 

 
Note: Auto-Crossover function is supported by the gateway. 
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5 Getting Started 
The following table provides an overview of the steps necessary for 
installing and commissioning the EU5C-SWD-PROFINET Gateway. 
 

 
Note: The gateway is shipped with its firmware already loaded.   
For information on how to update the firmware of the gateway, please 
refer to Updating Firmware chapter on page 90. 

 
# Step For details refer to  
1 Install gateway Chapter Installing EU5C-SWD-

PROFINET Gateway on page 
31 ff 

1.1 Take safety precautions  Section Safety Messages on 
page 31 

1.2 Mount gateway onto top hat rail Section Mounting Gateway onto 
Top Hat Rail on page 32 

1.3 Connect gateway to power supply Section Connecting Gateway to 
Power Supply on page 35 

1.4 Connect gateway to SmartWire-DT network Section Connecting SmartWire-
DT on page 37 

1.5 Connect gateway to PROFINET IO network Section Connecting PROFINET 
IO on page 38 

2 Commission gateway Chapter Commissioning EU5C-
SWD-PROFINET Gateway on 
page 40 ff 

2.1 Configure SmartWire-DT network in gateway Section Configuring SmartWire-
DT network in Gateway on page 
40  

2.2 Configure a PROFINET IO project for gateway Section Configuring Gateway in 
PROFINET IO Network on page 
43 

2.2.1 Import GSDML device description file in programming 
tool 

Section GSDML Device 
Description File on page 43 
Example for STEP 7: Section 
Import GSDML Device 
Description File on page 48  

2.2.2 Configure gateway in PROFINET IO project Example for STEP 7: Section 
Step-by-Step Instructions for 
Configuring Gateway with STEP 
7 on page 46 

2.2.3 Load PROFINET IO configuration to Controller/PLC Example for STEP 7: Section 
Step-by-Step Instructions for 
Loading PROFINET IO 
Configuration to S7-300 PLC on 
page 67 

2.3 Program Controller/PLC  Example for STEP 7: Section 
Step-by-Step Instructions for 
Programming in STEP 7: 
Display I/O Data on page 71 

Table 12: Getting Started 
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6 Installing EU5C-SWD-PROFINET Gateway 
6.1 Safety Messages 

 
 

 

 
Please observe the following safety messages when you install and  
handle the gateway! 

 First disconnect the power plug of the device. 
 Make sure that the power supply is off at the device. 
 Cover or enclose neighboring units that are live. 

 

 
 

 
Electrostatic Sensitive Device 

The gateway is sensitive to electrostatic discharge, which can cause 
internal damage and affect its normal operation. Therefore adhere to the 
necessary safety precautions for components that are vulnerable to 
electrostatic discharge, when you install or handle the gateway. 

 Do not touch the metal pins of the connectors of the gateway. 

 Touch a grounded object to discharge potential static. 

 Wear an approved grounding wriststrap. 

 If available, use a static-safe workstation. 

 When not in use, store the device in an appropriate static-safe 
packaging. 
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6.2 Mounting Gateway 
For mounting the EU5C-SWD-PROFINET Gateway onto a top hat rail, no 
tools are required. The back of the gateway  carries a spring-fitted bolt , 
by which the gateway can be clamped to the rail . 

 

 
Figure 5: Mounting Principle of the Gateway 

6.2.1 Mounting Gateway onto Top Hat Rail 
To mount the gateway onto the top hat rail, proceed as follows: 
 

 

 Make sure that the gateway is disconnected from any power supply. 
 Cover or enclose neighboring units that are live. 

 
 Tilt the gateway slightly and hook it 

into the upper railing from above, 
thereby pushing down the gateway 
with slight force, in order to 
overcome the resistance of the 
spring in the bolt. 

 

 
Figure 6: Hook Gateway to Upper 
Railing 
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 Keep on pushing the gateway 
downwards and tilt it back into 
vertical position, thereby hooking 
the gateway into the lower railing. 

 

 
Figure 7: Hook Gateway to Lower 
Railing 

 Let go of the gateway. The spring 
inside the bolt automatically pushes 
the gateway upwards into the 
railings, thereby fixing the gateway 
to the top hat rail. 

 
Figure 8: Gateway is Clamped to 
Top Hat Rail  
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6.2.2 Removing Gateway from Top Hat Rail 
To remove the gateway from the top hat rail, proceed as follows: 
 

 

 First disconnect the power plugs from the gateway. 
 Make sure that the power supply is off at the gateway. 
 Cover or enclose neighboring units that are live. 

 
 Push down the gateway with slight 

force (to overcome the resistance of 
the spring in the bolt), then unhook 
the gateway first from the lower 
railing and then from the upper 
railing.  

 

 
Figure 9: Unhook Gateway 
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6.3 Connecting Gateway to Power Supply 
 

 

  
In safety-relevant applications, the power supply providing power to the 
SmartWire-DT system must feature a PELV power feed module 
(protective extra low voltage). 

 

 

  
You must take safety precautions (emergency switching off) in the 
external circuitry of the EU5C-SWD-PROFINET Gateway and any power 
modules type EU5C-SWD-PF1-1 or EU5C-SWDPF2-1 that are used. To 
do so, plan to switch off the power supply to the contactor coils AUX. 

 

 

Important!  
Please take into consideration the total power consumption of your 
SmartWire-DT network and, if necessary, plan for an additional feeder 
module EU5C-SWD-PF2.   
You can find information on the power consumption in the operating 
manuals of the SmartWire-DT devices. 

 

 Connect the 24 V DC voltage to the POW terminals on the front side of 
the gateway. The POW connection provides the voltage for the gateway 
itself and for the SmartWire-DT slave electronics. 

 

 
Note: For the 15 V supply of the SmartWire-DT slaves, the gateway 
contains an additional power feed module with an amperage of 0.7 A. 
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 If necessary, connect the 24 V DC voltage for the contactor coils to the 
AUX terminals on the front side of the gateway. 

 
Figure 10: Gateway Power Supply  

 

 
Note: The AUX supply is required if any switching devices are also to be 
connected, for example, via the DIL-SWD-32-001/002 SmartWire-DT 
slaves. The AUX connection provides the supply for activating the 
contactor coils.
This supply must be protected by an automatic circuit-breaker (3A gG/gl or 
3 A miniature circuit-breaker with a Z characteristic).   
If switching devices with an activation power greater than 3 A are 
connected, an additional feeder module EU5C-SWD-PF1 or EU5C-SWD-
PF2 must be used. 

Potential conditions between the components  
The entire SmartWire-DT system operates on a common supply voltage. 
Provide a common star point for the earth wiring. In this way, the various 
slaves in the SmartWire-DT system will not be electrically isolated from one 
another.  
The PROFINET network and the SmartWire-DT system are electrically 
isolated from one another. 
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6.4 Connecting SmartWire-DT 
 Connect the SmartWire-DT network to the gateway. To do so, use the 

SmartWire-DT cable SWD4-100LF8-24 and the SWD4-8MF2 relevant 
blade terminal or prefabricated cables of type SWD4-(3/5/10)F8-24-2S. 

 

 
Figure 11: Connecting SmartWire-DT to Gateway  

 

 

 
Switch off the power supply, if you are reconnecting slaves in the 
SmartWire-DT system or reconnecting the ribbon cable connection. 
Otherwise the SmartWire-DT slaves can be destroyed! 

 

 

Note: Detailed instructions on adapting the SmartWire-DT external device 
plug (SWD4-8SF2-5) to the 8 pole Smart-Wire-DT cable are provided in 
chapter Fitting external device plugs SWD4-8SF2-5 of the manual 
SmartWire-DT – The System, MN05006002Z-EN (previously AWB2723-
1617en). 
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6.5 Connecting PROFINET IO  
 Connect the RJ45 plug of the PROFINET IO cable to one of the 

Ethernet connectors on the gateway. 

 

 
Figure 12: Connecting PROFINET IO to Gateway 

 

 

Important!  
Please observe the following notes on PROFINET IO cabling: 

 Do not use hubs. 
 Use switches only if the switch supports “Priority Tagging” and LLDP 
(100 MBit/s, Full Duplex). 

 Maximum cable length in a segment is 100 meters. 
Please also observe the following note on the cabling of the PROFINET 
IO Controller: 

 Connect only ports with each other which have different cross-over 
settings. Otherwise, a connection between the devices can not be 
established. If the port settings of the PROFINET IO Controller are not 
set to AUTO, then Port0 is switched uncrossed and Port1 crossed. 
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6.6 EMC-Conformant Wiring of the Network 
Undesired faults can occur on the bus due to electromagnetic interference.  
This can be minimized beforehand by the implementation of suitable EMC 
measures. These include: 

• EMC-conformant system configuration, 

• EMC compliant cable routing, 

• Measures that do not allow the occurrence of large differences in 
potential and 

• correct installation of the PROFINET system (cables, connection of the 
bus connectors, etc.) 

The effects of electromagnetic interference can be significantly reduced by 
fitting a shield.  

 

 

For detailed information on this, please refer to the PROFINET Installation 
Guideline for Cabling and Assembly, published by the PROFIBUS 
Nutzerorganisation e.V., Order No: 8.072. 
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7 Commissioning EU5C-SWD-PROFINET Gateway 
Before switching on, check whether the power supply for the gateway is 
connected correctly. The configuration and installation of the SmartWire-DT 
network must also have been carried out correctly (with all slaves 
connected). 

Commissioning takes place in several steps: 

1. Putting the SmartWire-DT network into operation. 

2. Create a connection to the PROFINET IO network. 

3. Configure PROFINET IO network and load configuration to PLC 
(PROFINET IO Controller). 

4. Write code for controller program and load it to PLC (PROFINET IO 
Controller). 

 

 
 

 
Danger of lethal injuries by unexpected starting up of motors or 
machinery! 
If you have already integrated devices into a system, secure the operating 
range of any connected parts of the system against access, so that 
nobody is endangered by motors or machinery starting up unexpectedly. 

 

7.1 Configuring SmartWire-DT network in Gateway 
Before the gateway can exchange data with the PLC, a valid SmartWire-DT 
network configuration (a so-called gateway target configuration) has to be 
stored in the gateway.   
This is compared with the current configuration (actual configuration) each 
time the gateway is restarted. If the gateway ascertains in this process that 
a SmartWire-DT slave cannot be reached or a wrong slave type is 
determined, the SmartWire-DT network will not go into operation (to be 
precise, this is dependent on the network configuration).   
Reading of the SmartWire-DT network configuration takes place by 
pressing the configuration button on the gateway (for the position of the 
configuration button, see figure Front View EU5C-SWD-PROFINET 
Gateway on page 25). All SmartWire-DT slaves are re-addressed in 
ascending order in the process.  

This process may only take place in the case of: 

• initial commissioning, 

• the replacement of a defective slave or 

• a change to the configuration. 

If a SmartWire-DT slave has failed, the SmartWire-DT network can still be 
operated with the remaining slaves, depending on the configuration setting 
(even after a repeat power up of the gateway). The failure is reported to the 
application.
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Important!  
If there is a faulty configuration and the configuration button is pressed, 
only the slaves up to the failed device are addressed and stored. Use of 
the remaining slaves is not possible until the defective slave has been 
replaced and the configuration has been read in again by pressing the 
configuration button. 

 

7.1.1 Reading the SmartWire-DT Configuration 
If you startup the gateway for the first time, or if you have replaced a 
SmartWire-DT slave or changed the setup of the SmartWire-DT network in 
some other way, you have to initiate a reading of the SmartWire-DT 
configuration. 

Prerequisites for reading the configuration are: 

• All SmartWire-DT slaves are connected to the SmartWire-DT line. 

• The SmartWire-DT network is connected to the gateway. 

• The voltage POW is applied to the coupling unit and the power LED 
POW is on. 

• The voltage AUX is applied (if necessary). 

• The SmartWire-DT status LEDs of the SmartWire-DT slaves are on or 
are flashing. 

 

 
Note: Disconnect the PROFINET IO network from the gateway by 
removing the RJ45 plug from the Ethernet interface of the gateway, before 
pressing the configuration button. 

 

 Press the configuration button on the gateway for at least two seconds 
(for the position of the configuration button, see figure Front View 
EU5C-SWD-PROFINET Gateway on page 25).  
Take care to push the button properly. You have to feel and overcome a 
slight resistance when pushing the button into the gateway, otherwise 
the button won’t trigger. 

 The SmartWire status LED on the gateway begins to flash orange. The 
SmartWire-DT status LEDs on the SmartWire-DT slaves also flash. 

 All slaves are addressed in sequence, the complete configuration is 
stored retentively as gateway target configuration. 

 The gateway then restarts. 
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7.1.2 Switching On Gateway When Target Configuration Is Stored  
If a configuration is stored in the gateway, each time the supply voltage is 
switched on, it is checked whether the slaves actually found on the network 
comply with the stored gateway target configuration.  

The result of the check is indicated by the SmartWire-DT status LED on the 
gateway (for the position of the LED, see section Positions of the LEDs on 
page 26): 

 
LED Color  State Meaning 

Duo-LED red/green/orange (orange = red/green at same time) 

 (green) On The current actual configuration complies with the gateway target 
configuration. 
Data exchange between gateway and SmartWire-DT slaves takes 
place. 

 (red) Flashing red A necessary SmartWire-DT slave is missing or the gateway target 
configuration does not comply with the actual configuration. 
No data exchange between gateway and SmartWire-DT slaves. 

 (green) Flashing 
green 

Slave addressing is active (after power-on or the download of a 
planned configuration with empty modules). 
No data exchange between gateway and SmartWire-DT slaves. 

 (red) On Short-circuit on the 15 V power supply or no SmartWire-DT slave is 
connected. 
No data exchange between gateway and SmartWire-DT slaves. 

SWD 
Status 
SmartWire-DT 

Number  in 
Figure 3 on 
page 26 
 

 (orange) 
Flashing After having pressed the configuration button: The gateway reads 

the current actual configuration and stores it as target configuration. 

Table 13: SWD LED 
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7.2 Configuring Gateway in PROFINET IO Network 

7.2.1 GSDML Device Description File 
In the PROFINET engineering tool of the PLC programming system, the 
EU5C-SWD-PROFINET Gateway is integrated as PROFINET IO Device – 
i. e. as slave device. For this, a device description file (GSDML file) 
containing a standardized description of the gateway is necessary.  

The ongoing development of the SmartWire-DT communication system 
results in different versions of the GSDML files. The relation between 
supported SmartWire-DT devices, gateway firmware versions and GSDML 
versions is shown in section Compatibility of SmartWire-DT Devices and 
Gateway on page 98. 

You will find the GSDML file on the product DVD in the  
EDS\EU5C-SWD-PROFINET directory. You can also download the latest 
version of a GSDML file from our website www.hilscher.com under Support 
> Downloads. 

Copy the relevant GSDML files together with the relevant bitmap files to the 
relevant directory of your PROFINET engineering tool or use the import 
function of the tool. For further information on this, please refer to the 
documentation of your engineering tool.  

 

7.2.2 Creating Communication With PROFINET IO  
If a data interchange is possible between the SmartWire-DT slaves and the 
gateway, in principle also communication between the gateway and the 
controller can be established via PROFINET IO. 

 Connect the gateway to the PROFINET IO bus. 

 Load the PROFINET IO configuration and possibly a controller program 
to the PLC. 

On uploading the PROFINET IO configuration/program from the 
engineering tool to the PLC, the configuration of the entire PROFINET IO 
network is transferred to the PROFINET IO Controller (master). The 
PROFINET IO Controller then transfers the planned SmartWire-DT 
configuration, which is included in the PROFINET IO configuration, to the 
gateway, where it is being tested.  

If the planned configuration complies with the stored gateway configuration, 
all status LEDs indicate a green continuous light. Any errors that occur are 
indicated via the Application status LED and the Config status LED. 

 

http://www.hilscher.com/
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LED Color State Meaning 

Duo-LED red/green 

 (green) On The communication on PROFINET and SmartWire-DT is in cyclic 
data exchange and the gateway function is executed. 

 (green) Flashing  
2 s off,  
0.5 s on 

Gateway is initialized, but the communication on PROFINET is not 
in cyclic data exchange. 

 (green) Flashing  
2 s off,  
0.5 s on, 
0.5 s off, 
0.5 s on 

Gateway is initialized, but the communication on SmartWire-DT is 
not in cyclic data exchange. 

 (red)  Flashing  
2 s off,  
0.5 s on 

Gateway is initialized, but the configuration for the communication 
protocol on PROFINET is missing or in error. 

 (red) Flashing  
2 s off,  
0.5 s on, 
0.5 s off, 
0.5 s on 

Gateway is initialized, but the configuration for the communication 
protocol on SmartWire-DT is missing or in error. 

APL 
Application 
status  

Number  in 
Figure 3 on 
page 26 
 

 (red) On Gateway has detected an error during the initialization: Missing 
configuration, error in configuration or internal error. 

Table 14: APL LED 

Prerequisite for data interchange is that the PROFINET configuration drawn 
up in the PROFINET engineering tool (= planned configuration) complies 
with the target configuration actually available on the gateway. The result of 
this check is signaled on the gateway by the SmartWire-DT configuration 
LED: 

 
LED Color State Meaning 

Duo-LED red/green 

 (green) On The planned configuration complies with the gateway target 
configuration. Data exchange between Gateway and PLC via 
PROFINET takes place. 

 (green) Flashing  The planned configuration does not comply with the gateway target 
configuration, but is compatible with it.  
Data exchange between gateway and PLC via PROFINET takes 
place. 

 (red) On The planned configuration and the gateway target configuration are 
not compatible. 
No data exchange between gateway and PLC via PROFINET. 

Config. 
Configuration 
status 

Number  in 
Figure 3 on 
page 26 

 (off) Off No communication with the PROFINET IO controller or the gateway 
does not contain a project configuration. 

Table 15: Config LED 
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7.3 Example: Using STEP 7 to Create a Gateway Project in 
PROFINET IO Network Controlled By S7-300 PLC  

7.3.1 Overview 
The following example shows how to use the STEP 7 programming 
software to configure and program the EU5C-SWD-PROFINET Gateway in 
a PROFINET IO network which is controlled by a S7-300 PLC. 

For this example, you need the following hard- and software: 

• PROFINET engineering tool:  
Programming device or PC with installed STEP 7 software  
(= programming system) 

• GSDML device description file for EU5C-SWD-PROFINET Gateway 

• S7-300 PLC 

• EU5C-SWD-PROFINET Gateway 

• PROFINET IO network 

• SmartWire-DT network with slaves  

 

To create and implement the gateway project, the following steps have to 
be performed in STEP 7: 

1. Create new project 

2. Import GSDML file 

3. Configure PROFINET IO Controller (S7-300 PLC) 

4. Configure PROFINET IO network 

5. Configure gateway in PROFINET IO 

6. Configure SmartWire-DT slaves in PROFINET IO 

7. Save and compile configuration 

8. Load configuration to S7-300 PLC (PROFINET IO Controller) 

9. Program controller 

10. Load controller program to S7-300 PLC (PROFINET IO Controller) 

 

 



Commissioning EU5C-SWD-PROFINET Gateway 46/103 

SmartWire-DT Gateway | EU5C-SWD-PROFINET  
DOC120304UM03EN | Revision 3 | English | 2012-07 | Released | Public  © Hilscher 2012 

7.3.2 Step-by-Step Instructions for Configuring Gateway with STEP 7 

7.3.2.1 Create Project in STEP 7 

1. Start STEP 7 SIMATIC Manager.  

 In the Windows Start menu, choose All Programs > SIMATIC > 
SIMATIC Manager. 

 The SIMATIC Manager opens. 

 If the STEP 7 Wizard: “New Project” appears, close the wizard by 
clicking the Cancel button. 

2. Create new project. 

 In the menu, choose File > New.  

 The New Project dialog box opens. 

 
Figure 13: Create New Project in SIMATIC Manager 

 In the User projects tab, use the Name field to enter the name of your 
project. In the Type drop-down list, select Project entry.  

 Click OK button. 

 The New Project dialog box closes, and a window containing the new 
project opens. 

3. Add PLC to the project. 

 In the project tree of the project window (in the left part of the project 
window), select your new project. 

 In the menu bar, choose Insert > Station > SIMATIC 300 Station.  
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 The PLC is displayed in the project window. 

 
Figure 14: PLC Added to the Project 

4. Open Hardware Configuration. 

 In the project tree, select SIMATIC 300(1) symbol, then double-click 
Hardware symbol in the right part of the project window. 

 The HW Config (Hardware Configuration) window for the project 
opens. 

 
Figure 15: Hardware Configuration Window 
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7.3.2.2 Import GSDML Device Description File 

 In the menu bar of the HW Config window, choose Options > Install 
GSD File…  

 The Install GSD Files dialog box opens: 

 
Figure 16: Install GSD Files Dialog Box 

 Choose the directory where the GSDML file you want to install is stored. 
In the drop-down list located next to the Install GSD Files entry, select 
from the directory entry, then click Browse… button. 

 The Windows Search Folder dialog opens. 

 Navigate to the relevant directory, select relevant folder and click OK 
button. 

 The Search Folder dialog closes, and in the Install GSD Files dialog 
box all GSD and GSDML files stored in that folder are displayed:  

 
Figure 17: Select GSDML File 
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Note: Usually the GSDML file is delivered together with a bitmap file 
containing an icon, which symbolizes the gateway in the GUI of the 
programming system. This bitmap file must be stored in the same folder 
as the GSDML file, so that it can automatically be installed together with 
the GSDML file. Please note, that this bitmap file is not displayed in the 
Install GSD Files dialog box, even if it’s actually there. Therefore, if you 
are in doubt, use the Windows Explorer to check whether the bitmap file is 
really present in the chosen folder. 

 

 Select the relevant GSDML file, then click Install button. 

 The GSDML file is installed. If an older version of the GSDML file has 
been installed before, this older file is transferred to a backup directory.  

 Acknowledge all messages by clicking Yes or OK.   
Click Close button to quit the Install GSD Files dialog box. 

 In the Hardware Catalog of the HW Config window, the EU5C-SWD-
PROFINET Gateway is displayed under PROFINET IO > Additional 
Field Devices > Gateway. 

 

 
Note: If the Hardware Catalog is not visible by default, you can open it in 
the menu bar of the HW Config window by choosing View > Catalog. 

 

 
Figure 18: Installed GSDML File  
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7.3.2.3 Configure PROFINET IO Controller  

1. Add rail (carrier rack) for IO Controller (PLC). 

 In the Hardware Catalog of the HW Config window, under SIMATIC 
300 > RACK-300, choose Rail object, and drag and drop it into the 
configuration window. 

 

 
Figure 19: Added Rail  

 The rail is displayed in the configuration window.  

2. Add power supply module for IO Controller (PLC). 

 In the Hardware Catalog of the HW Config window, under SIMATIC 
300 > PS-300, choose the appropriate power module, e. g. PS 307 
10A, and drag and drop it onto Slot 1 of the rail in the configuration 
window. 

 

 
Note: Once you have selected an object in the hardware catalog, all slots 
in the configuration window onto which the object can be dropped, are 
highlighted in a green color. This helps you to find the right slot. 
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Figure 20: Added Power Module  

 In the configuration window, the added power module is displayed in 
the rail.  

3. Add CPU for IO Controller (PLC). 

 In the Hardware Catalog of the HW Config window, choose the CPU 
you are using, e. g. SIMATIC 300 > CPU-300 > CPU 315-2 PN/DP > 
6ES7 315-2EH13-0AB0 > V2.6, and drag and drop it onto Slot 2 of the 
rail in the configuration window. 
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 On dropping the CPU onto the slot, the Properties – Ethernet 
Interface sheet automatically opens: 

 
Figure 21: Add CPU 

 In the Parameters tab of the Properties – Ethernet Interface sheet, 
enter IP address and Subnet mask or accept the preset default 
values. You can also set the IP address later during the next step, when 
you add a PROFINET IO network to the project. 

 

 
Note: Consult you network administrator about IP addresses, if you intend 
to use your company’s Ethernet network.  

 

 Click OK button, to close the Properties – Ethernet Interface sheet. 
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 After the Properties – Ethernet Interface sheet is closed, the added 
CPU with its interfaces is displayed in the rail in the configuration 
window:  

 
Figure 22: Added CPU  
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7.3.2.4 Configure PROFINET IO Network 

1. Add PROFINET IO network. 

 In the configuration window, right-click the X2 PN-IO interface, then 
choose Insert PROFINET IO System from the context menu. 

 The Properties – Ethernet Interface sheet, which you have already 
seen in the previous step when you added the CPU, opens again. The 
IP address and the Subnet mask are displayed in the Parameters tab 
and can be changed here once again. 

 
Figure 23: Add PROFINET IO (1) 

2. Set parameters for PROFINET IO network. 

 If necessary, change the values of the IP address and the Subnet 
mask in the Parameters tab. 

 In the Parameters tab, click New… button. 
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 The Properties – New subnet Industrial Ethernet sheet opens: 

 
Figure 24: Add PROFINET IO (2) 

 In the Name field of the Properties – New subnet Industrial Ethernet 
sheet, enter a new name for the network, or accept the preset default 
name. Then click OK button. 

 You are back in the Properties – Ethernet Interface sheet. 

 In the Properties – Ethernet Interface sheet, click OK button. 

 The Properties – Ethernet Interface sheet is closed, and in the 
configuration window, the newly added PROFINET IO network is 
depicted as PROFINET bus line.  

 
Figure 25: Added PROFINET IO Network  
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7.3.2.5 Configure Gateway in PROFINET IO  

1. Add Gateway. 

 In the Hardware Catalog, under PROFINET IO > Additional Field 
Devices > Gateway > EU5C-SWD, select the EU5C-SWD-PROFINET 
object and drag it into the configuration window, then drop it below the 
PROFINET bus line, which you have added in the previous step.  

 In the configuration window, the PROFINET bus line is depicted with 
the connected gateway:  

 
Figure 26: Added Gateway 

2. Set device name of gateway in PROFINET IO network. 

 In the upper part of the configuration window, double-click the gateway 
symbol. 
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 The Properties sheet of the gateway opens:  

 
Figure 27: Set Device Name of Gateway 

 In the Device name field of the General tab, you see the preset name 
of the gateway, which the STEP 7 software has taken over from the 
imported GSDML file. The PROFINET IO controller (the PLC) uses this 
name to address the gateway in the network.  

 Keep the preset name, if you intend to use only one EU5C-SWD-
PROFINET Gateway in your PROFINET network.   
If you intend to use more than one gateway, you must define a unique 
new name for each additional gateway. In that case you can keep the 
preset name for your first gateway, but have to enter a new Device 
name in the corresponding Properties sheets of the other gateways.  

 

 
Important: Please note that you need to define these new names not only 
within the STEP 7 configuration, but that you also need to transfer the 
new names onto the additional gateways and save them there, in order to 
overwrite the preset standard name stored in each gateway. Otherwise 
the additional gateways will not respond when contacted by the 
PROFINET IO controller.   
For information on how to change the device name on a gateway, see 
section Using STEP 7 to Assign Device Name or IP Address on the 
Gateway on page 81. 

 

 Click OK button to close the Properties sheet. 
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Note: If you have installed more than one version of a GSDML device 
description file in the course of time, you can use the Change Release 
Number… button in the General tab of the Properties sheet to open a 
dialog box, in which you can choose an older version of the GSDML file to 
be used to configure the gateway.  
Older versions of GSDML files are moved to a backup directory when new 
GSDML files are being imported to STEP 7, see Import GSDML Device 
Description File section on page 48. 

 

3. Define IP address for gateway in PROFINET IO. 

 In the upper part of the configuration window, right-click the gateway 
symbol, then choose Edit PROFINET IO System IP address from the 
context menu. 

 The Edit IP Addresses dialog box opens:  

 
Figure 28: Set IP Address of Gateway 

 Accept the IP address determined by the PROFINET IO controller, or 
click the IP Address field and enter a new address. 

 Click OK button to close Edit IP Addresses dialog box. 
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4. Set further parameters of gateway. 

 In the upper part of the configuration window, select the gateway 
symbol , then double-click the gateway entry on Slot 0  in the 
lower part of the configuration window. 

 
Figure 29: Set Further Gateway Parameters (1) 

 The Properties sheet opens.  
 

 
Note: The Gateways has two different Property sheets in STEP 7. 
One opens, if you double-click on the gateway symbol  in the upper part 
of the configuration window, the other opens, if you double-click the 
gateway entry on Slot 0  in the lower part of the configuration window. 

 

In the General tab, you can enter a comment: 

 
Figure 30: Set Further Gateway Parameters (2) 

 Click the Comment field and enter your text. 
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 After closing the Properties sheet, the text will be displayed in the 
Comment column in the lower part of the configuration window.  

In the Addresses tab, you can accept or change the preset diagnostic 
address of the gateway: 

 
Figure 31: Set Diagnostic Address of Gateway  

 Click the Diagnostic address field and enter the new address. 

In the Parameters tab, you can set the application parameters of the 
gateway in regard to its function as master in the SmartWire-DT network.  

 
Figure 32: Set Application Parameters of Gateway 
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 In the Value column, click the entry you want to change. As soon as 
you click a value, a drop-down list opens, in which you can select other 
values.  

You can set the following parameters: 
 

Parameter Value Description 
125 kBit/s  Baudrate SmartWire-DT 
250 kBit/s 

The baud rate of the SmartWire-DT network. 

No The planned SmartWire-DT slaves in the 
PROFINET IO configuration must comply 100 % 
with the SmartWire-DT slaves of the stored 
gateway target configuration. If not, no data 
interchange takes place with the PROFINET IO 
controller. 

Compatible devices 
allowed 

Yes Data exchange takes place, if the connected 
SmartWire-DT slaves are different but compatible 
with the planned SmartWire-DT slaves in the 
PROFINET IO configuration. This is indicated by 
the Config LED on the gateway. 

Defined for each 
slave  

Specification is performed individually for each 
SmartWire-DT slave.  

All slaves optional 

Yes Data transmission to the PROFINET IO also takes 
place for a random number of failed SmartWire-
DT slaves. The setting in the module parameters 
of the SmartWire-DT slaves has no effect.  
See Application Parameters of Slave table on 
page 66. 

Delay between cyclic 
exchange (ms) 

0  Reserved option, other settings currently not 
supported. 

Table 16: Application Parameters of Gateway 

 Click OK button to close the Properties sheet. 
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7.3.2.6 Configure SmartWire-DT Slaves in PROFINET IO 

1. Add SmartWire-DT slaves. 
 

 
Note: If you are using a project-specific GSDML device description file 
which was created by the SWD-Assist software and which contains 
preconfigured SmartWire-DT slaves, you don’t need to add and configure 
SmartWire-DT slaves as described in the subsequent section.  
For information on project-specific GSDML files created with SWD-Assist, 
please refer to the SWD-Assist online help. 

 

 In the configuration window, select the gateway symbol. 

 In the Hardware Catalog, select under PROFINET IO > Additional 
Field Devices > Gateway > EU5C-SWD > EU5C-SWD-PROFINET > 
Eaton a slave device of your SmartWire-DT network, e. g. EU5E-SWD-
2A2A in the Input / Output modules folder, then drag it into the lower 
part of the configuration window and drop it onto an appropriate slot of 
the gateway, e. g. Slot 1.   
Slots, onto which the device can be dropped, are highlighted in green 
color. 

 In the lower part of the configuration window, the added SmartWire-DT 
slave is displayed in the assigned gateway slot: 

 
Figure 33: Added SmartWire-DT Slave 

 Add other SmartWire-DT slaves as necessary. Proceed as described 
above.  
If you are not sure about the final SmartWire-DT topology, and perhaps 
wish to add SmartWire-DT slaves later, you can add a placeholder. For 
further information, see section Adding SmartWire-DT Slaves Later on 
page 79. 
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Important:  

 Observe the correct order of the SmartWire-DT slaves in the 
SmartWire-DT network. The SmartWire-DT slaves must be configured 
in PROFINET IO in the exact order according to their arrangement in 
the installation. 

 The universal module is not a valid SmartWire-DT slave and must not 
be added to the project.  

 

2. Configure SmartWire-DT slaves. 

 In the upper part of the configuration window, select the gateway 
symbol , then double-click the slave entry, e. g. EU5E-SWD-2A2A on 
Slot 1 , in the lower part of the configuration window. 

 
Figure 34: Configure SmartWire-DT Slave 
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 The Properties sheet opens. 

In the General tab, you can accept or change the preset name of the 
SmartWire-DT slave.  

 
Figure 35: Set Properties of SmartWire-DT Slave 

 Click Name field and enter a new name, if necessary. 

In the Addresses tab, you can accept or change the addresses, which are 
reserved within the controller for the input and output data of the 
SmartWire-DT slave. 

 
Figure 36: Set I/O Addresses of SmartWire-DT slaves, EU5E-SWD-2A2A Example 
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Note: On adding a SmartWire-DT slave, the addresses are assigned 
automatically by the system. The preset address value ensures that the 
start address is within the process image of the inputs and outputs.  

 

 Click the Start field and enter a new start address, if necessary. 

In the Parameters tab, you can set the application parameters of the 
SmartWire device in regard to its function as slave in the SmartWire-DT 
network. For example, you can parameterize the transient behavior for 
each SmartWire-DT slave. This defines how the gateway is to respond if an 
SmartWire-DT slave is not present. The standard setting is that all 
SmartWire-DT slaves have to be available. 
 

 
Note: The information as to whether a SmartWire-DT slave is available, is 
also reported to the application via the diagnostics function, so that you 
can respond there to the failure of an individual slave. 

 

 
Figure 37: Set Application Parameters for SmartWire-DT Slave, EU5E-SWD-2A2A Example 

 In the Value column, click the entry you want to change. As soon as 
you click a value, a drop-down list opens, in which you can select other 
values. 

Which application parameters can be set here, depends on the individual 
device characteristics of the SmartWire-DT slave.  
 

 

For information on individual device characteristics, please refer to the 
Eaton user manual SmartWire-DT Units, 05/11 MN05006001Z-EN. 
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For the EU5E-SWD-2A2A device you can set the following parameters: 
 

Parameter Value Description 
Device shall be present Data transfer to PROFINET takes place only if the SmartWire-DT 

slave is present. 
Presence of 
Device on SWD 
 Device shall not be 

present 
Data transfer to PROFINET takes place, even if the SmartWire-DT 
slave has failed or is not present. 

 

 

Note: Parameter setting at this point only makes sense, if in the application parameters of the gateway 
the All slaves optional parameter has been set to Defined for each slave.  
See Application Parameters of Gateway table on page 61. 

 
not allowed The SmartWire-DT slave may not be replaced by a universal module.  Replacement by 

universal module allowed The SmartWire-DT slave may be replaced by universal module M22-
SWD-NOP(C). 

Voltage (0-10V) Type of sensor 
input 0 Current (0-20mA) 

Voltage (0-10V) Type of sensor 
input 1 Current (0-20mA) 

Voltage (0-10V) Type of actuator 
output 0 Current (0-20mA) 

Voltage (0-10V) Type of actuator 
output 1 Current (0-20mA) 

Defines the type of sensor/actuator the SmartWire-DT slave is using 
(current- or voltage-based sensor/actuator) 
 

Measurement 
update time 

20 ms; 100 ms; 200 
ms; 500 ms 

Defines the refresh rate of readings. 

Averaging On; Off Switches averaging on/off 

Table 17: Application Parameters of Slave 

 Click OK button to close the Properties sheet. 

7.3.2.7 Save and Compile Configuration 

After you have finished to configure your PROFINET IO project, you must 
save and compile the configuration before you can upload it to your 
PROFINET IO controller, i. e. your S7-300 PLC. 

 In the menu bar of the HW Config window, choose Station > Save and 
Compile.  

 The hardware configuration is saved and compiled.  
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7.3.3 Step-by-Step Instructions for Loading PROFINET IO 
Configuration to S7-300 PLC 

Prerequisites 

• The S7-300 PLC is connected to power supply. 

• The S7-300 PLC is connected to the programming device/PC with 
installed STEP 7 software. 

Step-by-step instructions 
1. Set up PG/PC interface in STEP 7. 

 In the menu bar of the SIMATIC Manager on your programming 
device/PC, choose Options > Set PG/PC Interface… 

 The Set PG/PC Interface dialog box opens:  

 
Figure 38: Set PG/PC Interface (1) 

 In the Interface Parameter Assignment Used list of the Access Path 
tab, select the network interface card you are using on your 
programming device/PC.  

 Click Properties… button. 



Commissioning EU5C-SWD-PROFINET Gateway 68/103 

SmartWire-DT Gateway | EU5C-SWD-PROFINET  
DOC120304UM03EN | Revision 3 | English | 2012-07 | Released | Public  © Hilscher 2012 

 The Properties sheet for the selected network interface card opens:  

 
Figure 39: Set PG/PC Interface (2) 

 In the IE-PG Access tab, select Assign IP addresses unique to the 
project option, then click OK button. 

 You are back in the Set PG/PC Interface dialog box. 

 Click OK button, to take over the setting of the PG/PC interface. 

2. Load configuration to S7-300 PLC. 

 Open the HW Config window for the Project. 

 In the menu bar of the HW Config window, select PLC > Download…  

 The Select Target Module dialog box opens:  

 
Figure 40: Select Target PLC  

 In the Module list, select the target module (i. e. the CPU of the PLC), 
then click OK button. 
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 The Select Node Address dialog box opens:  

 
Figure 41: Select Node Address (1) 

 The CPU of the PLC is not yet displayed in the Accessible Nodes list. 

 Click View button. 

 The programming device/PC reads the MAC addresses of the 
connected devices and displays them in the Accessible Nodes list. 

 
Figure 42: Select Node Address (2) 
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 In the Accessible Nodes list, select the row featuring the MAC address 
of the CPU, then click OK button. 

 If no IP address has been assigned to the CPU before, the following 
Download message appears: 

 
Figure 43: Select Node Address (3) 

 Answer the question, whether the IP address should be assigned, with 
Yes. 

 The IP address is assigned to the CPU, and the configuration is loaded 
to the CPU of the PLC.  

 In the menu bar of the HW Config window choose Station > Exit to 
close HW Config. Answer the save prompt with Yes. 
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7.3.4 Step-by-Step Instructions for Programming in STEP 7: Display 
I/O Data 

The following step-by-step instructions provide a simple programming 
example for a PLC in STEP 7. It shows, how to monitor I/O data of the 
M22-SWD-K22LED-B function element, which is a SmartWire-DT slave 
controlled by a S7-300 PLC via the EU5C-SWD-PROFINET Gateway.  
For this, you must first define a “data block” and an “organization block” and 
load them to the PLC. Then you can visualize input and output data of the 
M22-SWD-K22LED-B slave in STEP 7 by means of a “variable table”, and 
send output data to the slave too. 

Prerequisites 

• You have already created, configured and loaded onto the S7-300 PLC 
a project containing a certain SmartWire-DT slave (in this case the M22-
SWD-K22LED-B function element). 

• Communication between PROFINET IO and SmartWire-DT network via 
gateway runs smoothly, cyclic data is exchanged. 

• The programming device/PC with installed STEP 7 software is 
connected to the S7-300 PLC. 

• You know the meaning of the input and output signals (e. g. the 
assignment of certain Bits to certain operational states) of the concerned 
SmartWire-DT slave.  

 

 

You will find the parameters of individual SmartWire-DT devices needed 
for programming in the Eaton user manual SmartWire-DT Units, 05/11 
MN05006001Z-EN. 

 

• The project is opened in the SIMATIC Manager. 

Step-by-step instructions 
1. Create data block.  

 In the project tree, select the CPU. 

 In the menu bar, choose Insert > S7 Block > Data block. 

 
Figure 44: Project Window in SIMATIC Manager 
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 The Properties sheet of the data block opens. 

 
Figure 45: Create Data Block 

 In the Name and type field of the General – Part 1 tab, enter the name 
of the data block, e. g. „DB100“, then click OK button. 

 The new data block is displayed in the Blocks node of the project 
window. 

 
Figure 46: Data Block Created 

2. Edit data block. 

 Select DB100 block. 

 Double-click DB100 block or choose Edit > Open Object in the menu 
bar.  
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 The data block is opened in the editor: 

 
Figure 47: Edit Data Block 

 Define Name, Type and Initial value of the elements which represent 
the input and output data. 

 In the menu bar of the editor, choose File > Save, then close the editor. 

3. Edit organization block. 
 

 
Note: You don’t need to create a new organization block (whereas you 
had to create a new data block), because each project by default already 
includes an OB1 organization block. 

 

 In the Blocks node of the project window, select the OB1 organization 
block. 

 Double-click OB1 block or choose Edit > Open Object in the menu bar.  

 If you open the OB1 organization block for the first time, the Properties 
sheet of the block opens. 

 Close the Properties sheet by clicking the OK button. 
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 The organization block is opened in the editor: 

 
Figure 48: Edit Organization Block 

 Link the elements representing the input and output data of the 
SmartWire-DT slave (i. e. DB100.DBB 1 and DB100.DBB 0 which 
you have defined in the data block) to the I/O addresses which were 
assigned to the SmartWire-DT slave when the project was being 
configured in PROFINET IO. (See section Configure SmartWire-DT 
Slaves in PROFINET IO.) If, for example, the value 256 was configured 
as I/O address, you must enter the programming code as shown in the 
picture above. 

 After you have entered the code, choose File > Save in the menu bar of 
the editor, then close the editor. 

4. Load blocks to S7-300 PLC. 

Before you can use a variable table to monitor input and output data of the 
SmartWire-DT slave, you must download the code/blocks to the PLC. 

 In the project tree, select Blocks node. 

 
Figure 49: Select Blocks Node in SIMATIC Manager 
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 In the menu bar of the SIMATIC Manager, choose PLC > Download. 

 The code/blocks are loaded to the PLC. 

5. Create variable table.  

 In the project tree, select the CPU. 

 
Figure 50: Selected CPU in Project Tree 

 In the menu bar of the SIMATIC Manager, choose Insert > S7 Block > 
Variable Table. 

 The Properties sheet of the variable table opens. 

 
Figure 51: Create Variable Table 

 In the Symbolic Name field of the General – Part 1 tab, enter the 
name of the table, e. g. „ VAT_1“, then click OK button. 
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 The new variable table is displayed in the Blocks node of the project 
window: 

 
Figure 52: Variable Table Created 

6. Edit Variable Table. 

 Select the variable table. 

 Double-click the variable table or choose Edit > Open Object in the 
menu bar.  

 The variable table is opened in the editor: 

 
Figure 53: Edit Variable Table  

 Fill in the Address and Display format columns as shown in the 
picture above. 

 In the menu bar of the editor, choose Table > Save. 

7. Display I/O data. 

 In the menu bar of the editor, choose Variable > Monitor, or click  
button in the toolbar of the editor.  
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 An online connection to the S7-300 PLC of this project is automatically 
established, and signals currently sent by the SmartWire-DT slave are 
displayed in the Status value column. 

 
Figure 54: Monitor Input Data  

If an event is triggered at the SmartWire-DT slave, the Status value of the 
DB100.DBB 0 element (which represents the input data) changes:  

 Push one of the buttons of the M22-SWD-K22LED-B slave device. 

 The corresponding Bit in the Status value column changes from 0 to 1. 
 

 

Information on the assignment of certain Bits to certain operational states, 
and other parameters needed for programming SmartWire-DT slaves, can 
be found in the Eaton user manual SmartWire-DT Units, 05/11 
MN05006001Z-EN. 

 

If the Modify value of the DB100.DBB 1 element (which represents the 
output data) is changed, an event at the SmartWire-DT slave can be 
triggered: 
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 In the variable table, change the last Bit of the Modify value of the 
DB100.DBB 1 element from 0 to 1. 

 
Figure 55: Modify Value  

 In the toolbar of the editor, click  button. 

 The LED at the M22-SWD-K22LED-B slave device lights up. 
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7.3.5 Adding SmartWire-DT Slaves Later 
If you are not sure about the final SmartWire-DT topology, and may wish to 
add SmartWire-DT slaves later, adding a placeholder (dummy module) in 
the appropriate position in the SmartWire-DT network is recommended. 
This is especially useful in STEP 7, since the HW Config tool does not 
allow the adding of stations between occupied module locations. 

 During configuration of the project in the engineering tool, position the 
permanent SmartWire-DT slaves in the correct order and add the 
Reserved (stored in the Other elements folder) element at the required 
position. 

 

 
Figure 56: Add Placeholder  

 The placeholder reserves a SmartWire-DT slave address for the 
SmartWire-DT slave which is to be added later. 

 Save the project, transfer it to the PLC. Then switch the PLC to RUN 
mode. 

 After the PROFINET IO configuration is received from the PLC, the 
SmartWire-DT gateway addresses the slaves automatically, taking the 
placeholder into account. 
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7.3.6 Acyclical Data Communication S7-300 PLC 
SmartWire-DT slaves – such as the PKE-SWD-32 module for the electronic 
motor-protective circuit-breaker – also supply acyclical data in addition to 
the cyclical data. The function blocks SFB52 RDREC (read record) and 
SFB53 WRREC (write record) are used in STEP 7 for reading and writing 
acyclical data.  
The reference to the required slave is implemented with these function 
blocks via the parameters ID and Index.  
 

 

For further information on handling these function blocks, please refer to 
the STEP 7 documentation. 

 

The address of the SmartWire-DT slave, with which communication is to be 
established, is set at the parameter ID. The Index parameter addresses the 
V1 object. The first object is assigned number 1, the second 2 etc. On the 
SmartWire-DT slave PKE-SWD-32, the object 1 supplies the current value 
Irel. 

For further information on acyclical data communication, see Acyclical 
Communication section on page 84. 

 



Commissioning EU5C-SWD-PROFINET Gateway 81/103 

SmartWire-DT Gateway | EU5C-SWD-PROFINET  
DOC120304UM03EN | Revision 3 | English | 2012-07 | Released | Public  © Hilscher 2012 

7.3.7 Using STEP 7 to Assign Device Name or IP Address on the 
Gateway 

You can use STEP 7 and your programming device/PC to assign to your 
gateway a new IP address or a new device name – independently from the 
PROFINET IO configuration. 

Prerequisites 

• The gateway is connected to power supply. 

• The gateway is connected via Ethernet to the programming device/PC 
and the STEP 7 software. 

• If you want to change the IP address of the gateway, the gateway must 
not be in a state of cyclic data exchange with the PROFINET IO 
controller. 

Step-by-step instructions 
 Open HW Config window for the project. 

 In the menu bar of the HW Config window, choose PLC > Ethernet > 
Edit Ethernet Node.  

  A blank Edit Ethernet Node dialog box opens:  

 
Figure 57: Edit Ethernet Node (1) 

 Below Nodes accessible online, click Browse… button. 
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 The Browse Network dialog box opens. After a short while, all found 
nodes are displayed:  

 
Figure 58: Browse Network 

 Select the entry for the gateway, then click OK button. 
 

 
Note: You can make the SF LED of the gateway flash, by clicking the 
Flash button in this dialog box. This may help you, to physically identify 
the gateway in a complex installation. Click Stop Flash button to switch 
off the LED. 

 



Commissioning EU5C-SWD-PROFINET Gateway 83/103 

SmartWire-DT Gateway | EU5C-SWD-PROFINET  
DOC120304UM03EN | Revision 3 | English | 2012-07 | Released | Public  © Hilscher 2012 

 The Browse Network dialog box closes, and the current address 
parameter of the gateway are taken over into the Edit Ethernet Node 
dialog box:  

 
Figure 59: Edit Ethernet Node (2) 

 If you want to change the IP Address:  
Enter the appropriate values in the IP address and Subnet mask 
fields, then click Assign IP Configuration button. 

 The IP address is transferred to the gateway and is stored in the 
gateway. 

 If you want to change the device name:  
Enter the new name in the Device name field, then click Assign name 
button. 

 The device name is transferred to the gateway and is stored in the 
gateway. 

 Click Close button to leave the Edit Ethernet Node dialog box. 
 

 
 

Important! 

Please note, that you also have to change the parameters in the 
PROFINET IO configuration accordingly, and that you have to load the 
adjusted configuration to the S7-300 PLC. 
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8 PROFINET IO Data Communication 
8.1 Acyclical Communication 

8.1.1 Address Mapping 
For acyclic communication, the read/write record services of the 
PROFINET IO controller are in the EU5C-SWD-PROFINET Gateway 
converted to SmartWire-DT read/write services and forwarded to the 
SmartWire-DT slaves. An address mapping enables the PROFINET IO 
Controller to access the SmartWire-DT slaves via the gateway.  

The following figure depicts the mapping of the PROFINET IO slot, subslot 
and index to SmartWire-DT slave and index. 
 

 
Figure 60: Acyclic Data Address Mapping 

The gateway is addressed by the PROFINET IO name of station. This 
makes is possible to address devices in the PROFINET IO network. 

The numbering of the slots corresponds to the sequence of the SmartWire-
DT slaves, i. e. Slot 1 is assigned to the first slave etc. 

The Subslot in PROFINET IO and in SmartWire-DT is always 1. 

The Index is passed on unaltered from SmartWire-DT to PROFINET IO. 
The meaning of the indexes depends on the individual SmartWire-DT 
slaves. 
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8.1.2 Error Detection and Error Codes 
The following figure shows at which points error detection is possible in 
acyclic communication.  

 
Figure 61: Acyclic Data Error Detection 

Errors detected in the gateway (PROFINET IO device) are reported as 
normal PROFINET IO errors to the controller. 

All errors, except addressing errors, which are detected on SmartWire-DT 
(master or slave) are reported with error code 0xDE80A000 (read) or 
0xDF80A100 (write) to the PROFINET IO controller.  

Error detection by the gateway for read/write records: 

An error code, e. g. 0xDE80B000, consists of an ErrorCode (DE = 
IODReadRes), ErrorDecode (80 = PNIORW), ErrorCode1 (B0 = invalid 
index) and ErrorCode2 (00 = not defined). 
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Error codes for read requests 
All error messages supported by the gateway concerning read requests 
start with:  
ErrorCode DE = IODReadRes = negative response to a read request,  
followed by:   
ErrorDecode 80 = PNIORW = user error.  
A description of ErrorCode1, which conveys the actual message, is 
provided in the following table. ErrorCode2 is not defined. 
 

Error 
message for 
read request 

ErrorCode1 Meaning 

0xDE80A0xx A0 Application error in SmartWire-DT  
0xDE80B0xx B0 Access invalid index 
0xDE80B2xx B2 Access invalid slot/subslot 
0xDE80B3xx B3 Access type conflict  
0xDE80B4xx B4 Access invalid area / API  
0xDE80B5xx B5 Access state conflict  
0xDE80B6xx B6 Access denied  
0xDE80B7xx B7 Access invalid range of a parameter/value 
0xDE80B8xx B8 Access invalid parameter  
0xDE80B9xx B9 Access invalid type 
0xDE80BAxx BA Access backup 
0xDE80BBxx BB Access user specific 7 
0xDE80BCxx BC Access user specific 8 
0xDE80BDxx BD Access user specific 9 
0xDE80BExx BE Access user specific 10 
0xDE80BFxx BF Access user specific 11 
0xDE80C0xx C0 Resource constrain conflict 
0xDE80C2xx C2 Resource busy 
0xDE80C3xx C3 Resource unavailable 
0xDE80C4xx C4 Resource not specified 1 
0xDE80C5xx C5 Resource not specified 2 
0xDE80C6xx C6 Resource not specified 3 
0xDE80C7xx C7 Resource not specified 4 
0xDE80C8xx C8 Resource user specific 12 
0xDE80C9xx C9 Resource user specific 13 
0xDE80CAxx CA Resource user specific 14 
0xDE80CBxx CB Resource user specific 15 
0xDE80CCxx CC Resource user specific 16 
0xDE80CDxx CD Resource user specific 17 
0xDE80CExx CE Resource user specific 18 
0xDE80CFxx CF Resource user specific 19 

Table 18: Acyclic Data Error Codes For Read Requests 
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Error codes for write requests 
All error messages supported by the gateway concerning read requests 
start with:  
ErrorCode DF = IODWriteRes = negative response to a write request,  
followed by:   
ErrorDecode 80 = PNIORW = user error.  
A description of ErrorCode1, which conveys the actual message, is 
provided in the following table. ErrorCode2 is not defined. 
 

Error 
message for 
write request 

ErrorCode1 Meaning 

0xDF80A1xx A1 Application error in SmartWire-DT  
0xDF80B0xx B0 Access invalid index 
0xDF80B2xx B2 Access invalid slot/subslot 
0xDF80B3xx B3 Access type conflict  
0xDF80B4xx B4 Access invalid area / API  
0xDF80B5xx B5 Access state conflict  
0xDF80B6xx B6 Access denied  
0xDF80B7xx B7 Access invalid range of a parameter/value 
0xDF80B8xx B8 Access invalid parameter  
0xDF80B9xx B9 Access invalid type 
0xDF80BAxx BA Access backup 
0xDF80BBxx BB Access user specific 7 
0xDF80BCxx BC Access user specific 8 
0xDF80BDxx BD Access user specific 9 
0xDF80BExx BE Access user specific 10 
0xDF80BFxx BF Access user specific 11 
0xDF80C1xx C1 Resource constrain conflict 
0xDF80C2xx C2 Resource busy 
0xDF80C3xx C3 Resource unavailable 
0xDF80C4xx C4 Resource not specified 1 
0xDF80C5xx C5 Resource not specified 2 
0xDF80C6xx C6 Resource not specified 3 
0xDF80C7xx C7 Resource not specified 4 
0xDF80C8xx C8 Resource user specific 12 
0xDF80C9xx C9 Resource user specific 13 
0xDF80CAxx CA Resource user specific 14 
0xDF80CBxx CB Resource user specific 15 
0xDF80CCxx CC Resource user specific 16 
0xDF80CDxx CD Resource user specific 17 
0xDF80CExx CE Resource user specific 18 
0xDF80CFxx CF Resource user specific 19 

Table 19: Acyclic Data Error Codes For Write Requests 
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8.2 Alarms and Diagnosis Controlled by the Gateway  
 

 
Figure 62: Diagnosis/Alarms 

Alarms can be process alarms (PA) or diagnosis alarms (DA). 

Process alarms are not issued by the gateway. 

Diagnosis alarms can be: 

• Return of submodule alarm 

• Pull alarm 

• Plug alarm 

• Diagnosis 

Return of submodule alarm 
Alarm issued for every plugged SmartWire-DT slave when SmartWire-DT 
returns from fail safe back to run normal state. 

Pull alarm 
Removal (pulling) or failure of a slave in the SmartWire-DT network leads to 
a pull alarm in PROFINET IO. 

Plug alarm 
Adding (plugging) or reinstalling a slave in the SmartWire-DT network leads 
to a plug alarm only if the concerned slave device is included in the target 
configuration.  
Adding a slave which is not included in the target configuration will not 
cause an alarm. 
 

 
Note: After having added a new slave device to the SmartWire-DT 
network, you need to disconnect the PROFINET IO from the gateway and 
read-in the new target configuration of the SmartWire-DT network (see 
Reading the SmartWire-DT Configuration section on page 41).  
Please note, that you also need to add the new slave to the PROFINET IO 
configuration. 
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Diagnosis 
Diagnosis data issued by a SmartWire-DT slave is forwarded to the 
PROFINET IO controller by the gateway using the following parameters: 
 

Parameter Value 
Slot Slot 0 = gateway reports 

Slot 1…99 = individual SmartWire-DT slaves 
SubSlot is always 1 
Channel Number 0x8000 (= Submodule) 
Channel Property is always 0 
ChannelErrorType see subsequent table 

Table 20: Diagnosis Parameters  

ChannelErrorType: 
PROFINET IO 
ChannelErrorType 

SmartWire-DT 
Diagnosis code 

Meaning Slot 

0x0107 - SmartWire-DT is in state fail safe 0 (gateway) 
0x0002 0x02 Supply voltage too low 
0x0004 0x13 Short-circuit/overload at supply voltage 
0x0005 0x01 Temperature too high 
0x0007 0x17 Out-of-range high reading on at least one 

temperature input 
0x0008 0x18 Out-of-range low reading on at least one 

temperature input 
0x0013 0x03 No communication with host system 
0x0100 0x14 Internal error 
0x0101 0x10 At device M22: contact in undefined position / 

contact in the middle position for longer than 
four seconds 

0x0102 0x11 At device M22: contact short-circuit 
0x0103 0x12 At device M22: contact resistance too high 
0x0105 0x16 S0 power meters invalid 
0x0106 0x15 No unambiguous position of the 1-0-A switch 

(auto/manual switch) for more than four 
seconds 

1…99 
(individual SWD-
salves) 

Table 21: Diagnosis ChannelErrorType  
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9 Updating Firmware 
The EU5C-SWD-PROFINET Gateway is shipped with its most recent 
firmware already loaded. The integrated web server of the gateway 
provides a function to update the firmware of the gateway by HTTP via its 
Ethernet interface. All you need is a PC with an ordinary web browser, 
connected to the gateway via the Ethernet network.  
 

9.1 Prerequisites 
• The gateway is connected to a power supply. 

• The gateway is connected to an IP network via its Ethernet interface.  

• PC with web browser connected to the IP network.  

• The IP address of the gateway is compatible to the Ethernet subnet of 
the PC. 

• You know the IP address of the gateway and user name and password 
needed for accessing the firmware update and reset functions of the 
web server.  
Default authentication parameters are:  
User Name: admin  
Password: admin 

 

 
Note: The current version of the firmware does not provide options to  
customize the user authentication of the web server by creating own 
groups, users or passwords.  

 

IP address of gateway 
On shipment, the default IP address of the gateway is 0.0.0.0. 

In principle, the gateway receives its IP address temporarily from the 
PROFINET IO controller via DCP protocol, and on each restart anew.  
A statically stored IP address can also be assigned to the gateway by the 
DCP protocol. The DCP protocol is standardized and usually supported by 
PROFINET IO engineering tools.  
Apart from address assignment by the PROFINET IO controller, you can 
assign the IP address of the gateway via DCP by using one of the following 
tools: 

• Hilscher Ethernet Device Configuration Tool.   
An installer for this program is stored on the product DVD in the directory 
Software\EnDeviceCfg. (It can also be installed by using the auto-
start menu of the Product DVD.)  
For further information about this tool, please refer to the operating 
instruction manual Ethernet Device Configuration, which is stored on the 
product DVD in the directory Documentation\english\Ethernet 
Device Configuration. 

• STEP 7. For further information, please refer to section Using STEP 7 to 
Assign Device Name or IP Address on the Gateway on page 81. 
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9.2 Step-by-Step Instructions for Updating Firmware  
 Start your web browser. 

 In the address bar of your browser, enter URL:   
http://<IP address>/fwupdate 

 The user authentication dialog opens.  

 Enter user name admin and password admin. 
 

 
Note: The current version of the firmware does not provide options to  
customize the user authentication by creating own groups, users or 
passwords. 

 

 The following web page opens: 
 

 
Figure 63: Firmware Update by HTTP (as depicted in Internet Explorer) 

The Firmware Identification section displays the following information: 

• Channel number (port number) 

• Name of loaded firmware 

• Firmware version 

• Date of firmware 

The Firmware Update section features the following control elements: 
 

Control element Function 
Selection field Shows selected file and its location. 
Browse… Opens the file selection dialog. 
Transfer Uploads selected firmware file to device. 
Cancel Cancels firmware update and clears selection field. 

Table 22: Controls in Firmware Update Page 

 Click Browse… button, to open a dialog box for selecting the firmware 
file. 
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 Select the firmware file and close the dialog box.  
 

 
Note: The filename extension of firmware files is .nxf 

 

 Path and name of the selected file are displayed in the field next to the 
Browse… button.  

 Click Transfer button to load the new firmware file to the gateway.  

 

 

 
Hazard of device damage by power failure during file transfer! 
Do not interrupt the power supply during transfer of the firmware file. 
A power failure while switching from the old to the already stored new 
firmware can cause severe malfunction of the device. 

 

 After you have started the upload by clicking the Transfer button, the 
validity of the firmware file is being checked by the system. If the file 
fails the validity check, the file will not be stored in the gateway and an 
error message will be displayed on the web page. If the file passes, a 
Transfer succeeded message will be displayed. 

 

 
Note: After successful transfer, you need to reset the gateway in order to 
start up the new firmware. 
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9.3 Resetting Gateway 
 In the address bar of your browser, enter URL:   
http://<IP address>/reset 

 If the user authentication dialog opens, enter user name admin and 
password admin. 

 The following web page opens: 
 

 
Figure 64: Reset by HTTP (as depicted in Internet Explorer) 

 

 
 

Important! 

Please note the following consequences of a reset: 

 The firmware is being restarted and connections will be interrupted or 
timed out. 

 I/O bus communication is being stopped. 

 The IP connection gets lost, if the gateway is not connected to a 
PROFINET IO controller and the IP address has not been permanently 
stored in the gateway. 

 

 Activate the checkbox in front of Please confirm… to acknowledge that 
you want to reset the device. 

 Then click Submit button to start the reset.  

You can use the Cancel button to uncheck the checkbox in front of Please 
confirm... 
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10 Technical Data 
10.1 Technical Data EU5C-SWD-PROFINET Gateway 

Category Parameter Value 
Part number 9233.920 

Dimensions  
(W x H x D) 

35 x 90 x 127 mm 

Weight 160 g 

Mounting Top hat rail 35 mm (IEC/EN 60715) 
Mounting position Vertical 
Standards IEC/EN 61131-2 

Communication controller netX 50 processor 

Diagnostic interface Mini-USB 

General 

Integrated memory 8 MB SDRAM 
4 MB serial Flash EPROM 

Protection type  
(IEC/EN 60529, EN50178, VBG 4) 

IP20 

Vibrations  
(IEC/EN 61131-2:2008) 

Constant amplitude 3.5 mm: 5 – 9 Hz 
Constant acceleration 1 g: 9 – 150 Hz 

Mechanical shock resistance  
(IEC/EN 60068-2-27) 

Semi-sinusoidal 15 g/11 ms: 9 Shocks 

Drop to  
(IEC/EN 60068-2-31) 

Drop height: 50 mm 

Ambient mechanical 
conditions 

Free fall, packaged  
(IEC/EN 60068-2-32) 

Drop height: 1 m 

Operating ambient temperature  
(IEC 60068-2) 

-25…+55 °C 

Condensation Prevent by suitable measures 

Storage -40…+70 °C 

Ambient climatic 
conditions 

Relative humidity, non-condensing 
(IEC/EN 60068-2-30) 

5…95 % 

Pollution degree 2 

Electrostatic discharge  
(IEC/EN 61131-2:2008) 

Air discharge (Level 3): 8 kV 
Contact discharge (Level 2): 4 kV 

Electromagnetic fields  
(IEC/EN 61131-2:2008) 

80 – 1000 MHz: 10 V/m 
1.4 – 2 GHz: 3 V/m 
2 – 2.7 GHz: 1 V/m 

Radio interference suppression 
(SmartWire-DT) 

EN 55011 Class A 

Burst  
(IEC/EN 61131-2:2008, Level 3) 

Supply cables: 2 kV 
PROFINET bus cable: 1 kV 
SmartWire-DT cables: 1 kV 

Surge  
(IEC/EN 61131-2:2008, Level 1) 

Supply cables: 0,5 kV 
PROFINET bus cable: 1 kV 

Electromagnetic 
compatibility (EMC) 

Radiated RFI 
(IEC/EN 61131-2:2008, Level 3) 

0.15 – 80 MHz, 10 V, 80% AM / 1 KHz 

Supply voltage UAUX Rated operational voltage 24 V DC 
-15 % +20 % 
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Category Parameter Value 
Input voltage residual ripple ≤ 5 % 

Protection against polarity reversal Yes 

max. current Imax 3 A 
Note: If contactors with a total power consumption 
> 3 A are connected, a power feeder module 
EU5C-SWD-PF1/2 has to be used. 

Short-circuit strength No, external fuse FAZ Z3 

Heat dissipation Typ. 1 W 

Potential isolation No 

Rated operating voltage of 24-V-DC 
slaves 

Typical UAUX -0,2 V 

Supply voltage 24 V DC 
-15 % +20 % 

Input voltage residual ripple ≤ 5 % 

Protection against polarity reversal Yes 

Rated operational current I 111 mA (with two participants) 

Heat dissipation at 24 V DC 2.66 W (with two participants) 

Potential isolation between UPOW 
and 15-V-SmartWire-DT supply 
voltage 

No 

Bridging voltage dips 10 ms 

Repeat rate 1 s 

Supply voltage UPOW 

Status display Yes 

Rated operational voltage Ue 15 V ± 3 % 

max. current Imax 0.7 A 
Note: If contactors with a total power consumption 
> 0.7 A are connected, a power feeder module 
EU5C-SWD-PF2 has to be used. 

SmartWire-DT supply 
voltage 

Short-circuit strength Yes 

Connection type Push-in terminals 

solid 0.2 – 1.5 mm2 (AWG 24 – 16) 

Connection supply 
voltages 

Flexible with ferrule 0.25 – 1.5 mm2 

Participant type SmartWire-DT master 

SmartWire-DT Master ASIC SWD-80P-RS485 

Number of SmartWire-DT slaves 99 

Baud rate 125 / 250 kBd 

Address setting Automatic 

SmartWire-DT network 

Status display SmartWire-DT master: SWD LED, duo color 
red/green 
Configuration: Config LED, duo color red/green 
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Category Parameter Value 
Connections Plug, 8-pole 

Plug connectors Blade terminal SWD4-8MF2 

Function PROFINET IO Device (Slave) 

Baud rate 100 MBit/s 

Interface type 100 BASE-TX 

Half duplex/full duplex Supported  

Auto-Negotiation Supported 

Auto-Crossover Supported 

Address setting  Automatically via PROFINET IO 

Status display  PROFINET IO device: APL, SF, BF LEDs, duo 
color red/green 

Connector socket 2 x RJ45 

Connector plug RJ45 

PROFINET IO network 

Potential isolation Yes  

Table 23: Technical Data EU5C-SWD-PROFINET Gateway 
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10.2 PROFINET IO Device (Slave)  
  

Parameter Description 
Maximum number of cyclic input data 800 bytes  
Maximum number of cyclic output data 642 bytes  
Maximum number of cyclic input/output 
data in sum 

1000 bytes 

Supported protocols RTC – Real Time Cyclic Protocol, Class 1 and 2 (unsynchronized) 
RTA – Real Time Acyclic Protocol  
DCP – Discovery and configuration Protocol  
CL-RPC – Connectionless Remote Procedure Call 
LLDP – Link Layer Discovery Protocol  
SNMP – Simple Network Management Protocol 

Used Protocols (subset) UDP, IP, ARP, ICMP (Ping)  
Topology recognition  LLDP, SNMP V1, MIB2, physical device  
VLAN- and priority tagging  Yes 
Context Management by CL-RPC  Supported 
Minimum cycle time 1 ms for RTC1 and RTC2 
Baud rate  100 MBit/s 
Data transport layer Ethernet II, IEEE 802.3  
Limitations RT over UDP not supported 

Multicast communication not supported 
Only one device instance is supported 
DHCP is not supported 
RT Class 2 synchronized (IRT “flex”) is not supported 
RT Class 3 synchronized not supported 
FastStartUp is not supported 
Media Redundancy (except MRP client) is not supported 
Access to the submodule granular status bytes (IOCS) is not supported 
The amount of configured IO-data influences the minimum cycle time 
that can be reached 
Supervisor-AR is not supported, Supervisor-DA-AR is supported 
Only 1 Input-CR and 1 Output-CR are supported 
Multiple WriteRequests are not supported  

Table 24: Technical Data PROFINET IO Device 
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10.3 Compatibility of SmartWire-DT Devices and Gateway 
 

SmartWire-DT slaves EU5C-SWD-PROFINET Gateway 
Firmware: E030D0U0.nxf 
Firmware version number: 1.0.x.x 
Hardware revision number: 3 
GSDML device description file: 
GSDML-V2.25-Hilscher-EU5C-SWD-201206xx.xml 

I/O modules  
EU5E-SWD-8DX √ 
EU5E-SWD-4D4D √ 
EU5E-SWD-4D2R √ 
EU5E-SWD-4DX √ 
EU5E-SWD-X8D √ 
EU5E-SWD-4AX √ 
EU5E-SWD-2A2A √ 
EU5E-SWD-4PT √ 
DIL/PKE modules  
DIL-SWD-32-001 √ 
DIL-SWD-32-002 √ 

PKE-SWD-32 Profile 1, 2, 3 √ 

PKE modules  

PKE-SWD Profile 1, 2, 3 √ 

Circuit breakers  

NZM-XSWD-704 Profile 1, 2, 3, 4 √ 

RMQ modules  
M22-SWD-K11 √ 
M22-SWD-K11LED-B √ 
M22-SWD-K11LEDC-B √ 
M22-SWD-K11LEDC-G √ 
M22-SWD-K11LEDC-R √ 
M22-SWD-K11LEDC-W √ 
M22-SWD-K11LED-G √ 
M22-SWD-K11LED-R √ 
M22-SWD-K11LED-W √ 
M22-SWD-K22 √ 
M22-SWD-K22LED-B √ 
M22-SWD-K22LEDC-B √ 
M22-SWD-K22LEDC-G √ 
M22-SWD-K22LEDC-R √ 
M22-SWD-K22LEDC-W √ 
M22-SWD-K22LED-G √ 
M22-SWD-K22LED-R √ 
M22-SWD-K22LED-W √ 
M22-SWD-KC11 √ 
M22-SWD-KC22 √ 
M22-SWD-LED-B √ 
M22-SWD-LEDC-B √ 



Technical Data 99/103 

SmartWire-DT Gateway | EU5C-SWD-PROFINET  
DOC120304UM03EN | Revision 3 | English | 2012-07 | Released | Public  © Hilscher 2012 

SmartWire-DT slaves EU5C-SWD-PROFINET Gateway 
Firmware: E030D0U0.nxf 
Firmware version number: 1.0.x.x 
Hardware revision number: 3 
GSDML device description file: 
GSDML-V2.25-Hilscher-EU5C-SWD-201206xx.xml 

M22-SWD-LEDC-G √ 
M22-SWD-LEDC-R √ 
M22-SWD-LEDC-W √ 
M22-SWD-LED-G √ 
M22-SWD-LED-R √ 
M22-SWD-LED-W √ 
Soft starter  

DS7-SWD PKE1 √ 

DS7-SWD PKE2 √ 

DS7-SWD PKE3 √ 

DS7-SWD PKE1-8Bit √ 

DS7-SWD PKE2-8Bit √ 

DS7-SWD PKE3-8Bit √ 

DS7-SWD PKE1-PD 2x16Bit √ 

DS7-SWD PKE2-PD 2x16Bit √ 

DS7-SWD PKE3-PD 2x16Bit √ 

DS7-SWD 8Bit √ 

DS7-SWD PD 2x16Bit √ 

Partner devices  

Phoenix Contact 
EM SWD-Adapter 

√ 

Wöhner 
WOE-SWD-ECS3D2D 

√ 

Wöhner 
WOE-SWD-AEL1DX 

√ 

Wöhner 
WOE-SWD-CL9AX 

√ 

Universal modules  
M22-SWD-NOP √ 
M22-SWD-NOPC √ 
Other elements  
Placeholder module (Reserved) √ 

Table 25:Compatibility of Devices 
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11.3 Contacts 
 

Headquarters 
 
Germany 
Hilscher Gesellschaft für  
Systemautomation mbH 
Rheinstrasse 15 
65795 Hattersheim 
Phone: +49 (0) 6190 9907-0 
Fax:     +49 (0) 6190 9907-50 
E-Mail: info@hilscher.com 
Support 
Phone: +49 (0) 6190 9907-99 
E-Mail: de.support@hilscher.com 
 

 
 
 
 
 
 
 
 
 
 
 
 

Subsidiaries 
 

 

China 
Hilscher Systemautomation (Shanghai) Co. Ltd. 
200010 Shanghai 
Phone: +86 (0) 21-6355-5161 
E-Mail: info@hilscher.cn 
Support 
Phone: +86 (0) 21-6355-5161 
E-Mail: cn.support@hilscher.com 
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Hilscher France S.a.r.l. 
69500 Bron 
Phone: +33 (0) 4 72 37 98 40 
E-Mail: info@hilscher.fr 
Support 
Phone: +33 (0) 4 72 37 98 40  
E-Mail: fr.support@hilscher.com 
 
India 
Hilscher India Pvt. Ltd. 
New Delhi - 110 065 
Phone:  +91 11 43055431 
E-Mail: info@hilscher.in 
 
Italy 
Hilscher Italia S.r.l. 
20090 Vimodrone (MI) 
Phone: +39 02 25007068 
E-Mail: info@hilscher.it 
Support 
Phone: +39 02 25007068 
E-Mail: it.support@hilscher.com 

Japan 
Hilscher Japan KK 
Tokyo, 160-0022 
Phone: +81 (0) 3-5362-0521 
E-Mail: info@hilscher.jp 
Support 
Phone: +81 (0) 3-5362-0521 
E-Mail: jp.support@hilscher.com 
 
Korea 
Hilscher Korea Inc. 
Suwon, Gyeonggi, 443-734 
Phone: +82 (0) 31-695-5515 
E-Mail: info@hilscher.kr 
 
Switzerland 
Hilscher Swiss GmbH  
4500 Solothurn 
Phone: +41 (0) 32 623 6633 
E-Mail: info@hilscher.ch 
Support 
Phone: +49 (0) 6190 9907-99 
E-Mail: ch.support@hilscher.com 
 
USA 
Hilscher North America, Inc.  
Lisle, IL 60532 
Phone: +1 630-505-5301 
E-Mail: info@hilscher.us 
Support 
Phone: +1 630-505-5301 
E-Mail: us.support@hilscher.com 
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